Bug #91777 main.basedir fails frequently
Submitted: 24 Jul 2018 11:17 Modified: 25 Jul 2018 0:55
Reporter: Dyre Tjeldvoll Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any

[24 Jul 2018 11:17] Dyre Tjeldvoll
Description:
The test main.basedir used to fail sporadically. Lately the failures come more frequently.

Root cause appears to be that running mysqld -D --init-file=x where x issues a shutdown can make the daemon go away before is has signaled a successful start to the launching grand-parent process. 

How to repeat:
Run test on a powerful machine

Suggested fix:
Using the --init-file option with shutdown was just done for simplicity. Re-write test case to launch the daemon aganinst the MTR datadir, connect and then perform a normal shutdown using the --shutdown-server command.
[25 Jul 2018 0:55] Paul Dubois
Posted by developer:
 
Fixed in 8.0.14.

Work was done for test suite. No changelog entry needed.