Bug #9176 Query coloring incorrect if string constant contains line break
Submitted: 14 Mar 2005 22:48 Modified: 28 Apr 2005 12:55
Reporter: Sergey Petrunya Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.1.6 OS:Microsoft Windows (win32)
Assigned to: Mike Lischke CPU Architecture:Any

[14 Mar 2005 22:48] Sergey Petrunya
Description:
Query coloring is incorrect if string constant contains line break. 
It is assumed that lines start outside of quotes.

How to repeat:
Try entering:
select 'ab
cd', 1+2;
See incorrect coloring at the second line.
[28 Apr 2005 12:55] Mike Lischke
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.mysql.com/documentation/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Additional info:

It is a common behavior that tokens in a text are are separated by either space, tab or line break. Although a string constant may contain spaces and tabs line breaks are not allow in any case. And since syntax highlighting works line by line it is also not easy to change.

Mike