Bug #9173 Ambiguous Error: 'Error While Storing the User Information'
Submitted: 14 Mar 2005 18:46 Modified: 3 Aug 2005 17:17
Reporter: Lynn Eriksen Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S3 (Non-critical)
Version:1.0.10 OS:Microsoft Windows (Windows)
Assigned to: Vladimir Kolesnikov

[14 Mar 2005 18:46] Lynn Eriksen
Description:
When trying to make changes to user accounts with Administrator 1.0.19 against server 4.1.10a I am getting the ambiguous 'Error While Storing the User Information'.

This error does not help me in any way resolve the problem.

Here is what I am trying to do:

1) I am creating a new user account.
2) I am trying to update the account by allowing a new host to login from.

I am allowing the use of old passwords for security and I am using a set of tables upgraded from 3.23 and 4.0. I have run the table fix script.

This use to work until about the 4.19 timeframe.

I have reset the char type on the user and db tables in the ',ysql' db to utf8. THis does not help

How to repeat:
I cannot repeat with a test local machine, only my production machine.

Suggested fix:
Return a meaningfull error or log to the windows event log. I'm trying to get enough info to help you. There is not enough info save in the query log.
[14 Mar 2005 19:02] Lynn Eriksen
I try to give you any information you need. Please contact me via e-mail.

If you need, send me a debug version and I'll send you results if you dump them to a file.
[14 Mar 2005 20:58] Miguel Solorzano
I wasn't able to repeat the beahvior reported.
[11 Apr 2005 8:28] Alex Lyons
I get this same problem. I am unable to save any changes to user data, in particular adding a hostname to an existing user, or making any changes to the GRANT tables.  I was eventually able to make the changes I needed by executing the appropriate SQL GRANT commands directly from the mysql command line.

I am using MySQL 4.11-nt-max, MySQL Administrator 1.0.19 (MySQL Client 5.0.0) on a Windows 2000 desktop. The mysql.user and mysql.user_info tables are MyISAM in charset utf8 and collation utf8_bin, as set by the installer.

Alex.
[21 Jul 2005 10:08] David Oliver
I'm also experiencing this issue. Have just setup fresh installations in Windows XP SP 2 of:

Apache 2.0.54
PHP 4.4.0
MySQL Server 4.1.13
MySQL Administrator 1.1.0 rc

Have ticked 'Use old passwords' as previous experience has taught me that PHP 4 doesn't work well otherwise.

Am trying to create a new user in Administrator (which superficially seems to work, ie. the user is in the list) but get the

'Error while storing the user information. The user might have been deleted. Please refresh the user list.'

If you need any specific information please let me know and I'll do my best to supply it, although I'm a novice at server stuff (I'm just trying to create a local test environment).

Thanks.
[21 Jul 2005 17:23] Crispin Hoult
I have on this server updated various versions of mysql 4.1.x and today updated to .13-nt and the Admin tool to 1.1.0rc

I cannot now edit permissions on users, though not sure last time I could sucessfully as the test DB is fairly static

Win2003 Std Edition SP1
[29 Jul 2005 10:27] Igor Bljahhin
I got same issue. I have just fresh installation on Windows XP:

MySQL Server 4.1.13
MySQL Administrator 1.1.0rc

I have created a new user in Administrator and now I'm trying to grant schema privileges to him.

Thanks.
[1 Aug 2005 15:34] Martin Trezise
same problem - MySQL Administrator V 1.1.0rc and mysql 4.1.13.nt used on winxp sp2
[2 Aug 2005 13:50] Halil Gurol
One more same problem, here is the details...

- mySQL Administrator V 1.1.0rc
- mySQL 4.1.13.nt
- win2003 SP1
[3 Aug 2005 13:30] Eric Lauterbach
When attempting to create a new user I too am receiving the error:

"Error while storing the user information. The user might have been deleted. Please refresh the user list."

This is a new, clean installation of the following products:
MySQL 4.1.13-nt via TCP/IP
MySQL Administrator 1.1.0 rc

On a Windows (Home) XP version 2002 SP2 development system (as an administrator-level user).

I am also running:
Apache 2.0.54 and
MySQL Query Browser 1.1.13
(if that helps in any way)

How I can repeat this error:
1. Open MySQL Admin (logging in as root).
2. Click "User Administration" option
3. Click "New User" button
4. Add new user ("testUser" with password "test")
5. Click "Apply Changes" button
6. Get error.

The new user "testUser" appears in the user list and does indeed exist in mysql.user as 'testUser'@'%' but a subsequent show grants query results in a "There is no such grant defined for user 'testUser' on host '%'" error notification.

Note that I am able to create a user at the command line level and through MySQL Query Browser.

If there is anything else I can do to help resolve this issue, please don't hesitate to contact me.
[3 Aug 2005 14:58] Volker von Minckwitz
Same problem. MySQL 4.1.13nt with MySQL Administrator 1.1.0rc. Problem is reproducable
[3 Aug 2005 17:17] Michael G. Zinner
Thank you for your bug report. This issue has already been fixed
in the latest released version of that product, which you can download at 
http://www.mysql.com/downloads/
[12 Aug 2005 21:37] Kevin Garber
Latest release for Win IS 4.1.13...and the bug is still there
[27 Sep 2005 16:20] Ricardo Proni
The problem occurs also in:
MySQL 5.0.13, MySQL Administrator 1.1.3, Windows XP Professional, whith a fresh instalation.
I am trying to create the user "nobody", without password, but I got the error "Error while storing user information...".
[28 Sep 2005 4:53] David Neal
I can confirm the same issue.

MySQL Administrator v1.1.3
MySQL v5.0.13
[28 Sep 2005 12:32] [ name withheld ]
Well, it hardly needs another 'me too' but..me too.

MySQL 5.0.13-rc-nt
MySQL Admin 5.0.11

On Win XP sp3.

I would use 4.1, but I'm only using MySQL because it now has stored procs, so if I can't use 5, I can't use MySQL in this case.
[28 Sep 2005 13:49] Guy Jascht
Have the same problem on 

MySQL 5.0.13-rc-nt-max
MySQL Administration 1.1.3
XP SP2
[28 Sep 2005 13:59] Scott Hamm
I am able to reproduce this problem.

Windows 2000 Pro
MySQL 5.0.13-rc
MySQL-Administrator-1.1.3
[28 Sep 2005 17:31] Vladimir Kolesnikov
Thank you for your bug report. This issue has already been fixed
in the latest released version of that product, which you can download at 
http://www.mysql.com/downloads/
[28 Sep 2005 18:40] Scott Hamm
Downloaded the latest version for Windows from link that you mentioned earlier and still have same problem.
[30 Sep 2005 6:49] Jos Helmich
I am running winxp sp2
mysql 5.0.13
mysql adminstrator for windows 1.13

I have the latest apache installed instead off IIS (turned off)

I get error above all the time: I cant add any users, and thus  not run any scripts without using the root user and its password.
[7 Oct 2005 3:04] Shawn Oster
Time to reopen this test case.  I'm getting the same error.  Fresh install of 5, client is 1.1.3 (just downloaded today, Oct 6th, 2005).  Works fine from the command line or from SQLyog, it's just from the Administrator tool it gives that error.
[14 Oct 2005 3:22] Jud Williams
Me too...

mysql-5.0.13-rc-win32.zip
mysql-admin-1.1.3-win.msi

both downloaded Oct 12.
[14 Oct 2005 18:48] John Inman
Ditto.
I have had this problem since day one.. Until now, I have been doing the "john-workaround" which is this..
((Currently on db_5.0.13, msyqladmin_1.1.3,running as root on localhost))
* Make user changes via Mysql-Admin.
* Push 'Apply'
* Accept the error by hitting 'OK'
* Click on different user
* Accept the message indicating 'User has been modified. Do you want to save changes?' by hitting 'YES'.
* Now click back to the initial user (the one that you changed)
+ You may have to do this process two times..
The 'Privileges' should now be changed.

Someone please look into this.
Could it have something to do with the 'user-account' that is using MysqlAdmin and the privileges assigned to that account?

Whats wierd is that if I am persistent enough.. the privileges will eventually get changed.
[30 Nov 2005 17:22] Adam Shackleford
* This bug is real.
* It exists in mysql-5.0.16-win32.zip under Windows 2000 SP4.
* It does not exist in mysql-4.1.15-win32.zip  under Windows 2000 SP4.
* Multiple reinstalls and reboots do not correct it.

1. PLEASE REOPEN THIS BUG
2. PLEASE ADJUST THE SEVERITY (not being able to create a user is definitely not "non-critical")
[2 Dec 2005 11:39] Jos Helmich
Does it help at all that we are complaining here for the bug to be reopened???
[2 Dec 2005 19:13] Chris Hall
This problem has been around for a year or more that I know of. It went away with an earlier version but seems to have returned with a download I did recently. You used to be able to fix this by changing the permissions on the root user and setting them all to 'Y' (they seem to be 'N' by default). I tried this and even this fails now. This error is super frustrating and given the number of posts I am far from being the only one with the issue. Can you please reopen this case.
[8 Dec 2005 18:16] Adam Shackleford
This is fixed in mysql-administrator-1.1.5-win.msi

Thanks, MySQL staff, for letting your customers know.
[27 Dec 2005 13:55] Robin Panicker
i am a Win Xp2 user with Sp2 i have installed Mysql 5.0.17 and mysql admin 1.1.2

when i try to add or update a user using Mysql admin it shows error 

"Error while storing the user info.The user details might have beendeleted.Pls refresh user list"

when i refresh the user list all information added or updated disappers

i was using 4.1 preveously i didn't have any problem with that

Pls mail me a way o fix this
[15 Feb 2006 17:32] Stuart Pentland
It appears to be back with Administrator 1.1.8 as I am now experiencing the same problem.

Setup on Windows:

Apache 2.0.55 
Mysql 4.1.7
PHP 4.4.2

Would appreciate a fix for this.
[5 May 2006 18:43] Kathy Mazur Worden
I've verified the bug today also.

MySQL Server 5.0.18-nt
MySQL Administrator 1.1.9

In User Administrator I type in the user name, enter the password both times, click on the Schema Priv tab and add the rights.  Clicking Apply shows the error:
Error while storing the user information.  The user might have been deleted.  Please refresh the user list.

If I click on a different user I'm prompted to save the changes made to the new account but clicking the Yes button only brings back the above message.
[11 Jun 2006 16:01] Greg Kutzbach
I have the same error.

Fresh install of WinXP Pro SP2 Fully patched and updated (6/11/06)
MySQL Administrator 1.0.21
MySQL Query Browser 1.1.20
MySQL 5.0 GA
[11 Jun 2006 16:16] Greg Kutzbach
I just upgraded to MySQL Administrator 1.1.9 and the error went away.
[23 Jun 2006 9:58] ulrike x
I have thsi problem with MySQL Administrator 1.1.9...
[10 Aug 2006 9:09] Robin Fairless
Same problem

WinXP Pro SP2 Fully patched and updated (August 10 2006)
MySQL Administrator 1.0.21
MySQL Query Browser 1.1.20
MySQL 5.0 GA

Strikes me as a critical issue. No user management!
[17 Nov 2006 11:45] jason nevin
Same bug. Created users from command line.
Administrator 1.1.1rc
MySQL v5.0.27
Client 5.04
XP SP2
[12 Sep 2007 5:25] mones jin
same problem,
MySQL 5.0.21
MySQL Administrator 1.1.3
Windows XP/2000 Server
[12 Sep 2007 7:33] mones jin
Guys, try--
mysql-gui-tools-5.0-r12-win32.msi--
it contains administrator and query browser.
And enable to add new user on MySQL 5.0.21
[23 Feb 2009 4:43] Jared S
One of my clients has the bug,
Administrator 1.2.16-and prior
MySQL 5.1.31
[20 Dec 2010 9:12] Bernard Ribot
Same problem with

MySQL Server 5.5.8
MySQL Administrator 1.2.17

Windows 7
[4 Feb 2011 0:46] Gerry Levasseur
Happy new year!  Problem is now 5 years old.  I have it with

MySQL Server 5.5.8
MySQL Administrator 1.2.17
Windows XP SP3

Also got SSL error when I tried Workbench 5.2.31
[7 Feb 2011 13:09] Hector Andres Chabur Tabares
El error todavia continua en mysql 5.5, ayuda please!!
[7 Feb 2011 13:46] Hector Andres Chabur Tabares
Encontre la solucion...

ALTER TABLE `user`  CHANGE COLUMN `authentication_string` `authentication_string` TEXT NULL COLLATE 'utf8_bin' AFTER `plugin`;

ejecutar esta consulta.
encontrada en: 
http://blogs.digitss.com/database/mysql/mysql-5-5-8-problem-while-creating-new-user-sql-er...
[7 Feb 2011 13:49] Hector Andres Chabur Tabares
ahora tengo otro error:
Could not fetch user names.
1142