Bug #91635 external component has thrown an exception
Submitted: 14 Jul 2018 6:03 Modified: 14 Jul 2018 19:20
Reporter: TAKASHI SUZUKI Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.10 OS:CentOS (7.5.1804)
Assigned to: CPU Architecture:x86
Tags: mysql server 8.0, workbench 6.3.10

[14 Jul 2018 6:03] TAKASHI SUZUKI
Description:
Dear forum member,

I have installed mysql 8.0 on CentOS7 (clean install with minimum). And I would like to connect mySQL workbench installed on Win10pro PC to mySQL.
I have encountered an error "external component has thrown an exception" on test connection of the workbench.
I assume to have to set something to "my.cnf" or others. So please let me know your comment.

I installed mysql as following procedure, see "How to repeat" please.

System Information:
CentOS Linux release 7.5.1804 (Core)
mysql  Ver 8.0.11 for Linux on x86_64 (MySQL Community Server - GPL)
M/B ASUS Z170-A, intel core i7, RAM 16GB, SSD 500GB
mySQL Workbench 6.3.10
Windows 10 Pro (1803) 

By the way, I could connect to mySQL 8.0 via console. Also I could connect to mySQL5.7 with same Workbench.

Thank you very much for your help.
Takashi

How to repeat:
After installation of centOS.
mySQL Install procedure (superuser mode):

# rpm -qa |grep maria
# yum remove mariadb-libs
# rm -rf /var/lib/mysql/
# yum -y update
# yum localinstall http://dev.mysql.com/get/mysql80-community-release-el7-1.noarch.rpm
# yum -y install mysql-community-server
# firewall-cmd --add-service=mysql --zone=public --permanent
# firewall-cmd --reload
# systemctl restart firewalld
# systemctl start mysqld.service
# cat /var/log/mysqld.log
# mysql_secure_installation --use-default
# mysql -u root -p
mysql> CREATE USER 'takashi'@'%' IDENTIFIED BY '********(password)';
mysql> GRANT ALL PRIVILEGES ON *.* TO 'takashi'@'%' WITH GRANT OPTION;

Here, I tried to connect mysql server from workbench on Win PC.
[14 Jul 2018 19:20] Miguel Solorzano
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=87380