Bug #91578 MySQL Workbench Directs One to a Web Page Rather than Actually Reporting the Bug
Submitted: 9 Jul 2018 16:06 Modified: 30 Jul 2018 16:11
Reporter: Jonathan Shaltz Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.3.10 OS:Microsoft Windows
Assigned to: CPU Architecture:x86
Tags: bug-reporting, workbench

[9 Jul 2018 16:06] Jonathan Shaltz
Description:
Come on guys, it's 2018.  When an app crashed, it should call home and submit a comprehensive but reasonably anonymous bug report, automatically.  At most, ask the user for permission first, with an option to not ask again.  That's very basic functionality, "ready for public beta" stuff.

How to repeat:
Crash the app.  So far, this has only happened once for me, though I've only been using it for a few hours total.

Suggested fix:
Bug reports should be submitted *automatically*.  Ask for permission if you like, and maybe provide space for user-provided details.
[10 Jul 2018 5:13] MySQL Verification Team
Hello Jonathan,

Thank you for the reasonable feature request!

Thanks,
Umesh
[30 Jul 2018 16:11] Mike Lischke
Posted by developer:
 
From a bug fixing point of view this is not a very welcome approach. To fix an issue you not only need the current status of the app, but exact steps to reproduce the crash. Only a manual report can achieve that, even in 2018.

Let's face it: those automatic bug reports help nothing to solve. They are mere statistic than actual bug reports. A robot counts how many people are affected (by trying to guess what belongs together), counts system libs and installed apps a user has and never gives any feedback. This is all but customer friendly. This is not what MySQL understands as real user support.