Bug #91535 Wordpress database connection error & Database was not shutdown normally
Submitted: 3 Jul 2018 6:39 Modified: 3 Jul 2018 7:12
Reporter: vinoth raja Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version: OS:Any
Assigned to: CPU Architecture:Any

[3 Jul 2018 6:39] vinoth raja
Description:
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

key_buffer_size=8388608
read_buffer_size=131072
max_used_connections=2
max_threads=600
thread_count=2
connection_count=2
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 246799 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x410a950
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7fa074321eb0 thread_stack 0x40000
/usr/sbin/mysqld(my_print_stacktrace+0x20)[0x8d7b60]
/usr/sbin/mysqld(handle_fatal_signal+0x481)[0x68b251]
/lib64/libpthread.so.0(+0xf890)[0x7fa0e0e3d890]
/usr/sbin/mysqld(mi_extra+0x16)[0x901756]
/usr/sbin/mysqld(_ZN13QEP_tmp_table8end_sendEv+0x48)[0x6e5b08]
/usr/sbin/mysqld(_Z13sub_select_opP4JOINP13st_join_tableb+0x33)[0x6e0813]
/usr/sbin/mysqld(_ZN4JOIN4execEv+0x2c0)[0x6df700]
/usr/sbin/mysqld(_Z12mysql_selectP3THDP10TABLE_LISTjR4ListI4ItemEPS4_P10SQL_I_ListI8st_orderESB_S7_yP13180619 11:46:39 mysqld_safe Number of processes running now: 0
180619 11:46:39 mysqld_safe mysqld restarted
2018-06-19 11:46:39 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-06-19 11:46:39 27463 [Note] Plugin 'FEDERATED' is disabled.
2018-06-19 11:46:39 27463 [Note] InnoDB: Using atomics to ref count buffer pool pages
2018-06-19 11:46:39 27463 [Note] InnoDB: The InnoDB memory heap is disabled
2018-06-19 11:46:39 27463 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-06-19 11:46:39 27463 [Note] InnoDB: Compressed tables use zlib 1.2.8
2018-06-19 11:46:39 27463 [Note] InnoDB: Using Linux native AIO
2018-06-19 11:46:39 27463 [Note] InnoDB: Using CPU crc32 instructions
2018-06-19 11:46:39 27463 [Note] InnoDB: Initializing buffer pool, size = 1.0G
2018-06-19 11:46:39 27463 [Note] InnoDB: Completed initialization of buffer pool
2018-06-19 11:46:39 27463 [Note] InnoDB: Highest supported file format is Barracuda.
2018-06-19 11:46:39 27463 [Note] InnoDB: Log scan progressed past the checkpoint lsn 50223797986
2018-06-19 11:46:39 27463 [Note] InnoDB: Database was not shutdown normally!
2018-06-19 11:46:39 27463 [Note] InnoDB: Starting crash recovery.
2018-06-19 11:46:39 27463 [Note] InnoDB: Reading tablespace information from the .ibd files...
2018-06-19 11:46:40 27463 [Note] InnoDB: Restoring possible half-written data pages 
2018-06-19 11:46:40 27463 [Note] InnoDB: from the doublewrite buffer...
InnoDB: Doing recovery: scanned up to log sequence number 50223797996
2018-06-19 11:46:41 27463 [Note] InnoDB: 128 rollback segment(s) are active.
2018-06-19 11:46:41 27463 [Note] InnoDB: Waiting for purge to start
2018-06-19 11:46:41 27463 [Note] InnoDB: 5.6.17 started; log sequence number 50223797996
2018-06-19 11:46:41 27463 [Note] RSA private key file not found: /var/lib/mysql//private_key.pem. Some authentication plugins will not work.
2018-06-19 11:46:41 27463 [Note] RSA public key file not found: /var/lib/mysql//public_key.pem. Some authentication plugins will not work.
2018-06-19 11:46:41 27463 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
2018-06-19 11:46:41 27463 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
2018-06-19 11:46:41 27463 [Note] Server socket created on IP: '127.0.0.1'.
2018-06-19 11:46:41 27463 [Note] Event Scheduler: Loaded 0 events
2018-06-19 11:46:41 27463 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.6.17'  socket: '/var/run/mysql/mysql.sock'  port: 3306  openSUSE package
09:46:42 UTC - mysqld got signal 11 ;

How to repeat:
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

key_buffer_size=8388608
read_buffer_size=131072
max_used_connections=2
max_threads=600
thread_count=2
connection_count=2
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 246799 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x410a950
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7fa074321eb0 thread_stack 0x40000
/usr/sbin/mysqld(my_print_stacktrace+0x20)[0x8d7b60]
/usr/sbin/mysqld(handle_fatal_signal+0x481)[0x68b251]
/lib64/libpthread.so.0(+0xf890)[0x7fa0e0e3d890]
/usr/sbin/mysqld(mi_extra+0x16)[0x901756]
/usr/sbin/mysqld(_ZN13QEP_tmp_table8end_sendEv+0x48)[0x6e5b08]
/usr/sbin/mysqld(_Z13sub_select_opP4JOINP13st_join_tableb+0x33)[0x6e0813]
/usr/sbin/mysqld(_ZN4JOIN4execEv+0x2c0)[0x6df700]
/usr/sbin/mysqld(_Z12mysql_selectP3THDP10TABLE_LISTjR4ListI4ItemEPS4_P10SQL_I_ListI8st_orderESB_S7_yP13180619 11:46:39 mysqld_safe Number of processes running now: 0
180619 11:46:39 mysqld_safe mysqld restarted
2018-06-19 11:46:39 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-06-19 11:46:39 27463 [Note] Plugin 'FEDERATED' is disabled.
2018-06-19 11:46:39 27463 [Note] InnoDB: Using atomics to ref count buffer pool pages
2018-06-19 11:46:39 27463 [Note] InnoDB: The InnoDB memory heap is disabled
2018-06-19 11:46:39 27463 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-06-19 11:46:39 27463 [Note] InnoDB: Compressed tables use zlib 1.2.8
2018-06-19 11:46:39 27463 [Note] InnoDB: Using Linux native AIO
2018-06-19 11:46:39 27463 [Note] InnoDB: Using CPU crc32 instructions
2018-06-19 11:46:39 27463 [Note] InnoDB: Initializing buffer pool, size = 1.0G
2018-06-19 11:46:39 27463 [Note] InnoDB: Completed initialization of buffer pool
2018-06-19 11:46:39 27463 [Note] InnoDB: Highest supported file format is Barracuda.
2018-06-19 11:46:39 27463 [Note] InnoDB: Log scan progressed past the checkpoint lsn 50223797986
2018-06-19 11:46:39 27463 [Note] InnoDB: Database was not shutdown normally!
2018-06-19 11:46:39 27463 [Note] InnoDB: Starting crash recovery.
2018-06-19 11:46:39 27463 [Note] InnoDB: Reading tablespace information from the .ibd files...
2018-06-19 11:46:40 27463 [Note] InnoDB: Restoring possible half-written data pages 
2018-06-19 11:46:40 27463 [Note] InnoDB: from the doublewrite buffer...
InnoDB: Doing recovery: scanned up to log sequence number 50223797996
2018-06-19 11:46:41 27463 [Note] InnoDB: 128 rollback segment(s) are active.
2018-06-19 11:46:41 27463 [Note] InnoDB: Waiting for purge to start
2018-06-19 11:46:41 27463 [Note] InnoDB: 5.6.17 started; log sequence number 50223797996
2018-06-19 11:46:41 27463 [Note] RSA private key file not found: /var/lib/mysql//private_key.pem. Some authentication plugins will not work.
2018-06-19 11:46:41 27463 [Note] RSA public key file not found: /var/lib/mysql//public_key.pem. Some authentication plugins will not work.
2018-06-19 11:46:41 27463 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
2018-06-19 11:46:41 27463 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
2018-06-19 11:46:41 27463 [Note] Server socket created on IP: '127.0.0.1'.
2018-06-19 11:46:41 27463 [Note] Event Scheduler: Loaded 0 events
2018-06-19 11:46:41 27463 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.6.17'  socket: '/var/run/mysql/mysql.sock'  port: 3306  openSUSE package
09:46:42 UTC - mysqld got signal 11 ;
[3 Jul 2018 6:53] vinoth raja
Please provide your feedbacks
[3 Jul 2018 7:12] Umesh Shastry
Thank you for taking the time to report a problem.  But version 5.6.17 is very old and the problem might already be fixed. Please try with current version 5.6.40/5.7.22/8.0.11 - http://www.mysql.com/downloads/

If you are able to reproduce the bug with one of the latest versions, please change the version on this bug report to the version you tested and change the status back to "Open".  Again, thank you for your continued support of MySQL.