Bug #91397 certification db size should limited or add to flow control
Submitted: 25 Jun 2018 4:38 Modified: 5 Nov 2018 3:36
Reporter: Zhenghu Wen (OCA) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Group Replication Severity:S4 (Feature request)
Version:5.7,8.0 OS:Any
Assigned to: Bogdan Kecman CPU Architecture:Any
Tags: certify

[25 Jun 2018 4:38] Zhenghu Wen
Description:
when i use sysbench(1.0 version) loading data to mgr, when prepare stage´╝îmysqld memory will periodly  growing rapidly and oom. 

the reason is:
sysbench 1.0 will first create table, loading data and create secondary index. 

when primary execute creating secondary index, the certification db size will be zero.

when secondary execute it, at this time, primary is inserting rows to new table, so certification db will insert more and more items(primary key of rows).

because secondary node could not increase gtid_executed when apply ddl, certification db could not do garbage collection.

if the memory is not so large for mysqld, mysqld will oom

How to repeat:
1. mgr single primary mode
2. using sysbench version equal or great than 1.0
3. and set --oltp-table-size param a very large number
4. do sysbench prepare

Suggested fix:
add certifiction database size into flow control system.
[2 Jul 2018 10:34] Bogdan Kecman
Hi,
I'm not sure what are you reporting here?
 - a problem with sysbench ?
 - a problem with certification process ?
 - a problem with mysql ?

mysqld will use ram according to how it is configured. If it's configured to use more ram then your system have it is either bad design of a system or bad configuration of mysqld but not a bug. Can you please elaborate what here you consider being a bug?

If you are talking about sysbench, please report the bug to sysbench
https://github.com/akopytov/sysbench

all best
Bogdan
[5 Nov 2018 3:36] Zhenghu Wen
change severity