Bug #91254 mysqlpump doesn't read "mysqlpump" group from option files
Submitted: 14 Jun 2018 11:49 Modified: 24 Jun 2018 7:54
Reporter: Mikiya Okuno Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: mysqlpump Command-line Client Severity:S3 (Non-critical)
Version:8.0.11 OS:Any
Assigned to: CPU Architecture:Any

[14 Jun 2018 11:49] Mikiya Okuno
Description:
According to the manual:

https://dev.mysql.com/doc/refman/8.0/en/mysqlpump.html

"mysqlpump supports the following options, which can be specified on the command line or in the [mysqlpump] and [client] groups of an option file."

However, it doesn't read [mysqlpump] group, but reads [mysql_dump] group. IMHO, the behavior written in the manual should be right. Using [mysql_dump] group is confusing.

How to repeat:
shell> mysqlpump --help | grep 'following groups'
The following groups are read: client mysql_dump

Suggested fix:
diff --git a/client/dump/program.cc b/client/dump/program.cc
index e348ee5b7dd..9b1326f116a 100644
--- a/client/dump/program.cc
+++ b/client/dump/program.cc
@@ -266,7 +266,7 @@ Program::Program()
 const char *load_default_groups[]=
 {
   "client", /* Read settings how to connect to server. */
-  "mysql_dump", /* Read special settings for mysql_dump. */
+  "mysqlpump", /* Read special settings for mysqlpump. */
   0
 };
[15 Jun 2018 2:58] tsubasa tanaka
This issue leaves about 18 months...
https://bugs.mysql.com/bug.php?id=83144
[24 Jun 2018 7:54] MySQL Verification Team
Marking this as duplicate of Bug #83144.