Bug #91247 MTS ordered commit may cause deadlocks on the slaves
Submitted: 14 Jun 8:13 Modified: 16 Jul 20:44
Reporter: Christian Hansen Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Replication Severity:S1 (Critical)
Version:5.7.22 OS:Ubuntu (16.04)
Assigned to: Bogdan Kecman CPU Architecture:x86

[14 Jun 8:13] Christian Hansen
Description:
When i enable MTS on my slaves I get deadlocks where selects wont go through and hangs and waiting for table lock. So the server goes into a deadlock.

Why is this ?

If i remove MTS again and run single thread it works fine

Regards Christian

Denmark

How to repeat:
Enable MTS on the slaves with these configs. GTID is not enabled

slave_preserve_commit_order=1
slave_parallel_type=LOGICAL_CLOCK
slave_parallel_workers=3
[16 Jul 20:44] Bogdan Kecman
Hi,
This is too broad description of the problem and I can't reproduce this. Can you give us a reproducible test case we can work with?

thanks
Bogdan