Bug #91077 [FAIL] Starting MySQL database server: mysqld . . . . . . . . failed!
Submitted: 30 May 2018 12:43 Modified: 15 Jun 2018 12:43
Reporter: Oleksii Dovzhenko Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.5.60 OS:Any
Assigned to: CPU Architecture:Any
Tags: IBData1

[30 May 2018 12:43] Oleksii Dovzhenko
Description:
180530 14:11:58 InnoDB: The InnoDB memory heap is disabled
180530 14:11:58 InnoDB: Mutexes and rw_locks use GCC atomic builtins
180530 14:11:58 InnoDB: Compressed tables use zlib 1.2.8
180530 14:11:58 InnoDB: Using Linux native AIO
180530 14:11:58 InnoDB: Initializing buffer pool, size = 128.0M
180530 14:11:58 InnoDB: Completed initialization of buffer pool
180530 14:11:58 InnoDB: highest supported file format is Barracuda.
InnoDB: Error: trying to access page number 19735 in space 0,
InnoDB: space name ./ibdata1,
InnoDB: which is outside the tablespace bounds.
InnoDB: Byte offset 0, len 16384, i/o type 10.
InnoDB: If you get this error at mysqld startup, please check that
InnoDB: your my.cnf matches the ibdata files that you have in the
InnoDB: MySQL server.
180530 14:11:58  InnoDB: Assertion failure in thread 140632953624384 in file fil0fil.c line 4578
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
12:11:58 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

key_buffer_size=16777216
read_buffer_size=131072
max_used_connections=0
max_threads=151
thread_count=0
connection_count=0
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 346701 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x30000
/usr/sbin/mysqld(my_print_stacktrace+0x33)[0x55fa59e2af33]
/usr/sbin/mysqld(handle_fatal_signal+0x3e4)[0x55fa59d16bc4]
/lib/x86_64-linux-gnu/libpthread.so.0(+0xf890)[0x7fe7a8fc9890]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0x37)[0x7fe7a79bf067]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x148)[0x7fe7a79c0448]
/usr/sbin/mysqld(+0x5f1eb7)[0x55fa59f33eb7]
/usr/sbin/mysqld(+0x5cba8d)[0x55fa59f0da8d]
/usr/sbin/mysqld(+0x5cc5b6)[0x55fa59f0e5b6]
/usr/sbin/mysqld(+0x5bb4ee)[0x55fa59efd4ee]
/usr/sbin/mysqld(+0x595096)[0x55fa59ed7096]
/usr/sbin/mysqld(+0x58aa60)[0x55fa59ecca60]
/usr/sbin/mysqld(+0x58b783)[0x55fa59ecd783]
/usr/sbin/mysqld(+0x58d1d5)[0x55fa59ecf1d5]
/usr/sbin/mysqld(+0x5799bc)[0x55fa59ebb9bc]
/usr/sbin/mysqld(+0x546145)[0x55fa59e88145]
/usr/sbin/mysqld(_Z24ha_initialize_handlertonP13st_plugin_int+0x3f)[0x55fa59d18dbf]
/usr/sbin/mysqld(+0x2f7891)[0x55fa59c39891]
/usr/sbin/mysqld(_Z11plugin_initPiPPci+0x903)[0x55fa59c3dd33]
/usr/sbin/mysqld(+0x27d898)[0x55fa59bbf898]
/usr/sbin/mysqld(_Z11mysqld_mainiPPc+0x45b)[0x55fa59bc485b]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7fe7a79abb45]
/usr/sbin/mysqld(+0x279258)[0x55fa59bbb258]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
It happened after I have not enough free space on /tmp/, I stoped the server, then I tried to launch the mysql server and I had an error that the server cannot create a file in /tmp/ directory. When the issue with free space was fixed and I tried to start the server again and I received this error.
[15 Jun 2018 12:43] Sinisa Milivojevic
Hi,

Thank you for your report.

Running out of the disk space is very hard problem. It is expected that in such situations your data will be corrupted. We recommend re-installation from the last backup.

If you can repeat the same scenario with sufficient space on disks, we would like to have a test case that we can repeat on every attempt.

In that case, please use some newer version 5.6 and 5.7, since 5.5 receives patches only for security bugs.