Bug #91056 mysqld got signal 6
Submitted: 29 May 2018 7:52 Modified: 29 May 2018 9:25
Reporter: mark huang Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:mysql5.7.17 OS:CentOS (7.2)
Assigned to: CPU Architecture:x86 (virtual machine)
Tags: mysqld got signal 6

[29 May 2018 7:52] mark huang
Description:
2018-05-28T00:46:30.213044Z 34 [Warning] IP address 'XXXX' could not be resolved: Name or service not known
terminate called after throwing an instance of 'std::out_of_range'
  what():  vector::_M_range_check
00:50:46 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

key_buffer_size=8388608
read_buffer_size=131072
max_used_connections=22
max_threads=151
thread_count=22
connection_count=22
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 68275 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x40000
/data/application/mysql/bin/mysqld(my_print_stacktrace+0x2c)[0xedbb1c]
/data/application/mysql/bin/mysqld(handle_fatal_signal+0x451)[0x7acea1]
/lib64/libpthread.so.0(+0xf370)[0x7f5bf6558370]
/lib64/libc.so.6(gsignal+0x37)[0x7f5bf51581d7]
/lib64/libc.so.6(abort+0x148)[0x7f5bf51598c8]
/lib64/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x165)[0x7f5bf5a5c9d5]
/lib64/libstdc++.so.6(+0x5e946)[0x7f5bf5a5a946]
/lib64/libstdc++.so.6(+0x5e973)[0x7f5bf5a5a973]
/lib64/libstdc++.so.6(+0x5eb93)[0x7f5bf5a5ab93]
/lib64/libstdc++.so.6(_ZSt20__throw_out_of_rangePKc+0x77)[0x7f5bf5aafa17]
/data/application/mysql/bin/mysqld[0x1133386]
/data/application/mysql/bin/mysqld[0x11360ce]
/data/application/mysql/bin/mysqld(_Z17dict_stats_updateP12dict_table_t23dict_stats_upd_option_t+0x1205)[0x1139055]
/data/application/mysql/bin/mysqld(dict_stats_thread+0x8e6)[0x113b236]
/lib64/libpthread.so.0(+0x7dc5)[0x7f5bf6550dc5]
/lib64/libc.so.6(clone+0x6d)[0x7f5bf521a76d]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
2018-05-28T00:50:46.425627Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-05-28T00:50:46.425696Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release.
2018-05-28T00:50:46.425700Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set.
2018-05-28T00:50:46.425725Z 0 [Note] --secure-file-priv is set to NULL. Operations related to importing and exporting data are disabled
2018-05-28T00:50:46.425763Z 0 [Note] /data/application/mysql/bin/mysqld (mysqld 5.7.17-log) starting as process 17707 ...
2018-05-28T00:50:46.430319Z 0 [Note] InnoDB: PUNCH HOLE support available
2018-05-28T00:50:46.430347Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-05-28T00:50:46.430353Z 0 [Note] InnoDB: Uses event mutexes
2018-05-28T00:50:46.430358Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2018-05-28T00:50:46.430362Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3
2018-05-28T00:50:46.430367Z 0 [Note] InnoDB: Using Linux native AIO
2018-05-28T00:50:46.430635Z 0 [Note] InnoDB: Number of pools: 1
2018-05-28T00:50:46.430754Z 0 [Note] InnoDB: Using CPU crc32 instructions
2018-05-28T00:50:46.432229Z 0 [Note] InnoDB: Initializing buffer pool, total size = 4G, instances = 8, chunk size = 128M
2018-05-28T00:50:46.667442Z 0 [Note] InnoDB: Completed initialization of buffer pool
2018-05-28T00:50:46.702053Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2018-05-28T00:50:46.714358Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2018-05-28T00:50:46.737725Z 0 [Note] InnoDB: Log scan progressed past the checkpoint lsn 474155446219
2018-05-28T00:50:46.807320Z 0 [Note] InnoDB: Doing recovery: scanned up to log sequence number 474160688640
2018-05-28T00:50:46.904610Z 0 [Note] InnoDB: Doing recovery: scanned up to log sequence number 474159246848
2018-05-28T00:50:47.017593Z 0 [Note] InnoDB: Doing recovery: scanned up to log sequence number 474164489728
2018-05-28T00:50:47.180740Z 0 [Note] InnoDB: Doing recovery: scanned up to log sequence number 474169732608
2018-05-28T00:50:47.223908Z 0 [Note] InnoDB: Doing recovery: scanned up to log sequence number 474170930756
2018-05-28T00:50:47.225088Z 0 [Note] InnoDB: Database was not shutdown normally!
2018-05-28T00:50:47.225109Z 0 [Note] InnoDB: Starting crash recovery.
2018-05-28T00:50:47.256103Z 0 [Note] InnoDB: 1 transaction(s) which must be rolled back or cleaned up in total 125469 row operations to undo
2018-05-28T00:50:47.256139Z 0 [Note] InnoDB: Trx id counter is 325579776
2018-05-28T00:50:47.271069Z 0 [Note] InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percent: 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 
2018-05-28T00:50:47.887729Z 0 [Note] InnoDB: Apply batch completed
2018-05-28T00:50:47.887780Z 0 [Note] InnoDB: Last MySQL binlog file position 0 19253381, file name mysql-bin.000208
2018-05-28T00:50:48.025376Z 0 [Note] InnoDB: Starting in background the rollback of uncommitted transactions
2018-05-28T00:50:48.025419Z 0 [Note] InnoDB: Rolling back trx with id 325579464, 125469 rows to undo

InnoDB: Progress in percents: 12018-05-28T00:50:48.027646Z 0 [Note] InnoDB: Removed temporary tablespace data file: "ibtmp1"
2018-05-28T00:50:48.027660Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2018-05-28T00:50:48.027700Z 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2018-05-28T00:50:48.042052Z 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2018-05-28T00:50:48.042942Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.
2018-05-28T00:50:48.042953Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
2018-05-28T00:50:48.043372Z 0 [Note] InnoDB: Waiting for purge to start
 22018-05-28T00:50:48.093465Z 0 [Note] InnoDB: 5.7.17 started; log sequence number 474170930756
2018-05-28T00:50:48.093631Z 0 [Note] InnoDB: Loading buffer pool(s) from /data/application/mysql/data/ib_buffer_pool
2018-05-28T00:50:48.093973Z 0 [Note] Plugin 'FEDERATED' is disabled.
2018-05-28T00:50:48.098800Z 0 [Note] Recovering after a crash using mysql-bin
 3 4 5 6 72018-05-28T00:50:48.177108Z 0 [Note] Starting crash recovery...
2018-05-28T00:50:48.177164Z 0 [Note] Crash recovery finished.
 8 9 10 112018-05-28T00:50:48.228623Z 0 [Warning] Failed to set up SSL because of the following SSL library error: SSL context is not usable without certificate and private key
2018-05-28T00:50:48.228836Z 0 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
2018-05-28T00:50:48.228864Z 0 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
2018-05-28T00:50:48.228892Z 0 [Note] Server socket created on IP: '0.0.0.0'.
2018-05-28T00:50:48.238150Z 0 [Note] Event Scheduler: Loaded 0 events
2018-05-28T00:50:48.238182Z 0 [Note] WSREP: Initial position: 992d6214-2d60-0000-e04c-be0100000000:214748364848
2018-05-28T00:50:48.238187Z 0 [Note] WSREP: wsrep_load(): loading provider library 'none' 

How to repeat:
the cash is happened in May 20th and   May 28th .
[29 May 2018 9:25] Shane Bester
This is a known and fixed bug.  Please upgrade to newer version to get the fix.

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-18.html

InnoDB: An error in code related to table statistics raised an assertion in the dict0stats.cc source file. (Bug #24585978)
[29 May 2018 9:29] Shane Bester
https://support.oracle.com/knowledge/Oracle%20Database%20Products/2249231_1.html