Bug #9094 Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COE
Submitted: 10 Mar 2005 13:30 Modified: 15 May 2005 5:14
Reporter: joe byers Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:1.1.6 OS:Microsoft Windows (Winxp and linux)
Assigned to: CPU Architecture:Any

[10 Mar 2005 13:30] joe byers
Description:
Executing the following statement
select * from pjmwork.nodecounts where zone_source not in ('AEP');
I get the synopsis error.

This error occurs on both winxp and linux versions of query browser when querying a Mysql db on a linux system.  It does not occur when querying a Mysql db on a winxp system. 

The not in syntax fails.  If I do a zone_source<>'AEP the query returns the correct results. 

I have tried everything relating to collations and related mysql db options to get this to work.  Other posts in the forums have referenced the internal setting of querybrowser.

I also have sqlyog software and the query above works correctly.  As does toadmysql.  Because these other two softwares correctly execute the query with zone_source not in ('AEP'), I am certain this is a bug in querybrowser.

How to repeat:
Execute a query with a not in componet on a linux system or connect to the mys ql db on a linux system from a winxp and execute the query.

Suggested fix:
See reference to sqlyog and toadmysql above.
[11 Mar 2005 22:59] Jorge del Conde
Hi

I was unable to repeat this bug report.  I tried executing the following queries and they all worked as expected:

use mysql;
SELECT * FROM user where Host not in ('localhost');
SELECT * FROM user where Host is not null;

Can you please give me an example query using the tables in the mysql database that cause this behaviour ?

Thanks
[11 Mar 2005 23:52] Jorge del Conde
Hi!

I just changed the status of this bug report to 'Need Feedback'

Could you please send me a copy of your tables so that I can reproduce this bug ?

Thanks a lot.
[12 Mar 2005 5:06] joe byers
zipped file of table and table definition

Attachment: nodecounts.zip (application/x-zip-compressed, text), 3.07 KiB.

[12 Mar 2005 5:06] joe byers
I added the files and for closing the bug, no problem.  Happens sometimes.

thanx again
[12 Mar 2005 21:23] Emanuele Dolis
Jorge,
sorry if i add a comment here, but i think it's the same bug as 9006 - just to make sure that you and Hartmut Holzgraefe are not doubling the work.... 
Bye
Emanuele
[19 Mar 2005 7:23] joe byers
Emanuele and Jorge

This bug is very similar to 9006 with a couple of specific added.

This bug occurs when querying a mysqldb on a linux server (redhat 9) from both the linux and a winxp systems versions of query browser.  The linux system is querying the server localhost or the hostname for the linux server, both fail.

The error DOES NOT occur when querying a mysqldb on winxp localhost server using the winxp version of querybrowser.

It should be noted that the same version of querybrowser is used on the winxp box for both test queries.

thanx again and good luck
joe
[19 Apr 2005 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[19 Apr 2005 23:59] joe byers
I would like to update the severity from non-critical to serious.
[15 May 2005 5:14] joe byers
This is still a problem.  Does anyone know the status of this problem.  Because the collation does not work in mysqlquerybrowser, I have to use sqlyog on my xp box, which is not a bad thing for the xp box.  But, on linux, I am out of luck.