Bug #90841 relay-log-info-repository=TABLE option is not being picked up from options file
Submitted: 11 May 2018 23:15 Modified: 26 Jul 2018 10:36
Reporter: Sterling Cox Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Replication Severity:S2 (Serious)
Version:5.7.22-log OS:Red Hat (7.4)
Assigned to: Bogdan Kecman CPU Architecture:Any

[11 May 2018 23:15] Sterling Cox
Description:
Exactly the behavior described in https://bugs.mysql.com/bug.php?id=68485 , only with 5.7 on an EC2 RedHat 7 instance.

relay-log-info-repository=TABLE added to my.cnf has no effect. However, when changed in a running instance, the change works.

The value must be stored somewhere other than in configuration files, because it persists through restarts independent of what value is set in configuration files.

How to repeat:
What we learned: Trying to set relay-log-info-repository=TABLE on a RedHat 7 instance with /etc/my.cnf and nothing in /etc/my.cnf.d, and nothing in /etc/sysconfig/mysql, we added relay-log-info-repository=TABLE to my.cnf and when we restarted the server, show global variables like 'relay_log_info_repository' resulted in:

| relay_log_info_repository | FILE                             |

Even adding 

# Start main service
ExecStart=/usr/sbin/mysqld --daemonize --pid-file=/var/run/mysqld/mysqld.pid --relay-log-info-repository=TABLE $MYSQLD_OPTS

to /lib/systemd/system/mysqld.service has no effect on the value when the server is restarted.

However, when the value is changed in the running server with

SET @@global.relay_log_info_repository = 'TABLE';

the value sticks and persists through restarts, independent of values configured in /etc/my.cnf, /etc/my.cnf.d/*, or  /lib/systemd/system/mysqld.service
[22 Jun 2018 17:31] Bogdan Kecman
Hi,

Weird, it works normally for me! Lemme test with your config file

all best
Bogdan
[26 Jul 2018 10:36] Bogdan Kecman
Hi,

I am not able to reproduce this. 
Are you using binary from Oracle or you are pulling some binary amazon repo gives you access to ? With Oracle binary everything works ok, I can not reproduce the behavior you are reporting, not even on EC2 machine.

kind regards
Bogdan