Bug #90838 InnoDB: While importing db using transportable tablespaces slave getting unrespo
Submitted: 11 May 2018 14:02 Modified: 11 May 2018 15:00
Reporter: Ramesh Sencha Email Updates:
Status: Unsupported Impact on me:
None 
Category:MySQL Server: Errors Severity:S3 (Non-critical)
Version:Percona MySQL 5.7 OS:Any
Assigned to: CPU Architecture:Any

[11 May 2018 14:02] Ramesh Sencha
Description:
What we are trying to achive :
We wanted to import big DB's from one cluster to other cluster using tranportable tablespaces.

Architecture :
 Master slave architecture

Issue Description :
While working on importing table spaces with bin log disable we observed that on slave mysql service is becoming unresponsive in middle of import process.
To import DB schema first we are copying all ibd/cfg files after putting lock with "FLUSH TABLES t FOR EXPORT;"  with schema. Then we are copying on desired server (cluster which is also running with master slave [active-passive]) and first import schema and then using following approach for each table on both slave and master :
1. Disable BIN LOG
2. Discard table space using "ALTER TABLE t DISCARD TABLESPACE;"
3. Copy ibd & cfg files under data directory 
4. Import table space using "ALTER TABLE t IMPORT TABLESPACE;"

I am able to import multiple table but on specific table slave become unresponsive and our process get terminated. Following is error we observed on slave mysql error logs :


2018-05-10T18:19:20.897758Z 592694 [ERROR] InnoDB: Trying to access page number 2148504327 in space 947623, space name perf_amazon_dev472_v21/invoice_lines, which is outside the tablespace bounds. Byte offset 0, len 16384, i/o type read. If you get this error at mysqld startup, please check that your my.cnf matches the ibdata files that you have in the MySQL server.
2018-05-10T18:19:20.897803Z 592694 [ERROR] InnoDB: Server exits.

I have tried with another DB of having size around 1+ GB and for that it worked fine. But for DB having around 50GB is getting failed.

I have tried 2 time for DB having size of 50GB and faced same issue both the times. BTW I have also observed heaving load on server while doing this activity. Not sure load is expected or not.

Could you please suggest something to resolve the same ?

How to repeat:
Try to import large DB using transportable table space feature.
[11 May 2018 14:59] Miguel Solorzano
Thank you for the bug report. This bug system is for MySQL binaries bug, please file the bug at Percona Bug System. Thanks.