Bug #9081 Can't create temporary tables
Submitted: 9 Mar 2005 18:50 Modified: 11 Mar 2005 13:49
Reporter: joel schwartz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:4.1.8-nt OS:Microsoft Windows (windows xp pro)
Assigned to: CPU Architecture:Any

[9 Mar 2005 18:50] joel schwartz
Description:
I can't create a temporary table with the QUERY BROWSER. 

create temporary table a select * from <tablename>

Response "query returned no resultset". The table is not created. Also the word 'temporary' is not highlighted in blue as are other reserved words.

How to repeat:
Run:

create temporary table a select * from <tablename>

in the Query browser and the command line client.
It will only work in the command line client.
[9 Mar 2005 20:11] Emanuele Dolis
Hm,
I have experienced the same and it was a bit confusing - actually, yet, i think that tmp1 is created... but maybe for a specific connection (so when you try to issue some statement based on the temp table you've just created, it finds nothing, since temp tables are valid only for the same connection).
If you embed the temp table creation with the query using the table into a script, and you run it within QB, everything works fine.

The same problem happens, for instance, with parameters (if you SET a @parameter and then you try to access it, no value is retrieved)
It would be nice to have at list a stable connection per each resultset windows.... so that you use tmp tables on the fly and parameters as well :) 
I completely agree with you!
[11 Mar 2005 13:49] MySQL Verification Team
Duplicate of bug #4544