Bug #90721 High contrast screen mode does not affect the Workbench display.
Submitted: 2 May 2018 19:29 Modified: 6 Jun 2018 6:02
Reporter: Bobby Trapp Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S4 (Feature request)
Version:6.3.10 OS:Windows (Microsoft Windows 7 Enterprise Service Pack 1)
Assigned to: CPU Architecture:x86 (Intel i7)
Tags: WBBugReporter

[2 May 2018 19:29] Bobby Trapp
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\nh228uf.CSD\AppData\Roaming\MySQL\Workbench\log\wb.log]

When switching the Windows screen to high contrast mode (for use by a person with a vision impairment), some parts of the Workbench display do not change.  In particular, the script panes and the navigator pane are not affected.  Since the script pane is critical to writing SQL script, this is a problem for the user.

Additionally, some rows in the output pane change to black background with black text.  The examples with this condition were output from USE statements and with CALL statements.  An example not affected in this way is the output associated with a SELECT statement.

NOTE: This is a shared computer is being used in a classroom environment, so display switching is done on a per-student basis.

How to repeat:
Open Windows, right-click on the Desktop and choose "Personalize".  Select one of the available High Contrast Modes.  Open Workbench, load, and run a SQL script.

Suggested fix:
Make changes to the styling process for the script pane so it will be responsive to high contrast mode or make a high contrast styling option for the script pane.
[6 Jun 2018 6:02] MySQL Verification Team
Thank you for the feature request, this is duplicate of Bug #72372