Bug #90617 using gdb to attach mysqld will shutdown the instance
Submitted: 25 Apr 3:28 Modified: 29 May 1:49
Reporter: zhai weixiang (OCA) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.0.11 OS:Any
Assigned to: CPU Architecture:Any

[25 Apr 3:28] zhai weixiang
Description:
While testing the latest MySQL8.0.11, I found that the server was shutdown while using pt-pmp/pstack or directly gdb to get stack. 

How to repeat:
I'm not sure if it's common in all systems, bellow is may enviroment:

MySQL Version: 8.0.11
RedHat linux 2.6.32

$gdb --version
GNU gdb (GDB) Red Hat Enterprise Linux (7.2-50.1.alios6)

Suggested fix:
startup mysqld, using gdb to attach mysqld, or just send two singals: SIGSTOP and SIGCONT
[28 May 7:28] Valeriy Kravchuk
I can not reproduce this on Ubuntu 14.04 (with different kernel and gdb versions).

Had you built your binaries from source (and what was cmake command line then) or used some built by Oracle for RHEL/Oracle Linux 6.x? Is that alios6 a kind of/close to centos 6?
[29 May 1:49] zhai weixiang
Hi,  Valeriy
It seems like that the gdb on my testing machine was not correctly installed. I didn't have time looking into what was missing. But afer reinstalling the gdb, everything goes well. 
So, I'll close this bug as "Not a Bug"