Bug #9059 New Windows installer changes meaning of "default" location for my.ini file
Submitted: 8 Mar 2005 22:28 Modified: 9 Mar 2005 21:03
Reporter: Timothy Smith Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:4.1 OS:Microsoft Windows (Windows)
Assigned to: CPU Architecture:Any
Triage: D4 (Minor)

[8 Mar 2005 22:28] Timothy Smith
Description:
The docs repeatedly mention the fact that the default location for the config file is C:\WINDOWS\my.ini, or C:\my.cnf.  And this is indeed where the server looks by default, unless passed that --defaults-file argument on the command line.

The problem is that with the new installer, the user isn't aware that --defaults-file="<installation directory>/my.ini" is passed to the server.  So a user who wants to tweak the config file will be looking in C:\my.cnf or C:\WINDOWS\my.ini and not find it there.  Instead they must look in (for example) "C:\Program Files\MySQL\MySQL 4.1\my.ini".

This is now the *default* behavior for most new Windows installations.

How to repeat:
Install MySQL from the MSI package, and follow the normal installation sequence.

Suggested fix:
Update the sections of the manual that talk about my.ini locations, so that users of the Windows installer will know to look in the installation directory instead of on C:\.
[9 Mar 2005 21:03] Mike Hillyer
Added references to new location in sections of the refman that deal with the location of my.ini, also added xrefs to the section of the Windows install chapter that deal with the location of the my.ini file.