Bug #90562 mysqlsh: weird sql error
Submitted: 23 Apr 2018 6:50 Modified: 26 Apr 2018 16:02
Reporter: Kenny Gryp Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Document Store: MySQL Shell Severity:S3 (Non-critical)
Version:8.0.11 OS:Any
Assigned to: CPU Architecture:Any

[23 Apr 2018 6:50] Kenny Gryp
Description:
weird sql error, didn't expect that:

 MySQL  mysql4:33060+ ssl  SQL > SELECT * FROM performance_schema.replication_connection_status\G
ERROR: SqlResult.fetchOne: Valid month range is 1-12

How to repeat:
 MySQL  JS > \c root@mysql4
Creating a session to 'root@mysql4'
Enter password: *
Fetching schema names for autocompletion... Press ^C to stop.
Your MySQL connection id is 36 (X protocol)
Server version: 8.0.11 MySQL Community Server - GPL
No default schema selected; type \use <schema> to set one.

 MySQL  mysql4:33060+ ssl  JS > \sql
Switching to SQL mode... Commands end with ;

 MySQL  mysql4:33060+ ssl  SQL > SELECT * FROM performance_schema.replication_connection_status\G
ERROR: SqlResult.fetchOne: Valid month range is 1-12

Suggested fix:
return the result?
[23 Apr 2018 16:58] Juan Rene Ramirez Monarrez
Hi Kenny

It would be very helpful if we can get a dump of the table being selected, if that's possible.

Thanks!
[24 Apr 2018 6:22] Umesh Shastry
Hello Kenny,

Thank you for the report.

Thanks,
Umesh
[26 Apr 2018 16:02] Alfredo Kojima
This is a duplicate of bug #90355