Bug #90506 5.7.21 on Ubuntu Bionic: -DWITH_SSL=system fails, -DWITH_SSL=bundled works
Submitted: 19 Apr 2018 7:56 Modified: 20 Apr 2018 8:20
Reporter: Roel Van de Paar (OCA) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Compiling Severity:S1 (Critical)
Version:5.7.21, 5.7.22 OS:Ubuntu (Bionic)
Assigned to: CPU Architecture:Other (x64)

[19 Apr 2018 7:56] Roel Van de Paar
Description:
[...]
                 from /git/mysql-server_dbg/vio/viossl.c:23:
/usr/include/openssl/err.h:247:1: note: declared here
 DEPRECATEDIN_1_1_0(void ERR_remove_thread_state(void *))
 ^
In file included from /git/mysql-server_dbg/include/my_global.h:642:0,
                 from /git/mysql-server_dbg/vio/vio_priv.h:22,
                 from /git/mysql-server_dbg/vio/viossl.c:23:
/git/mysql-server_dbg/vio/viossl.c: In function 'ssl_do':
/git/mysql-server_dbg/vio/viossl.c:422:44: error: dereferencing pointer to incomplete type 'SSL_COMP {aka struct ssl_comp_st}'
         DBUG_PRINT("info", ("  %d: %s\n", c->id, c->name));
                                            ^
/git/mysql-server_dbg/include/my_dbug.h:84:27: note: in definition of macro 'DBUG_PRINT'
               _db_doprnt_ arglist; \
                           ^~~~~~~
cc1: all warnings being treated as errors
make[2]: *** [vio/CMakeFiles/vio.dir/viossl.c.o] Error 1
vio/CMakeFiles/vio.dir/build.make:110: recipe for target 'vio/CMakeFiles/vio.dir/viossl.c.o' failed

How to repeat:
Compile MS 5.7.21 on a standard Ubuntu Bionic install (server image; http://cdimage.ubuntu.com/ubuntu-server/daily/current/ ) and use -DWITH_SSL=system. Using -DWITH_SSL=bundled works.
[19 Apr 2018 9:26] Umesh Shastry
Hello Roel,

Thank you for the report.

Thanks,
Umesh
[19 Apr 2018 18:46] Laurynas Biveinis
Likely duplicate of https://bugs.mysql.com/bug.php?id=83814
[20 Apr 2018 8:20] Terje Røsten
Correct, this is duplicate and will be fixed in 5.7.23.