Bug #90476 MySQL Workbench 6.3.9.0 unexpected exeception
Submitted: 17 Apr 2018 16:34 Modified: 18 Apr 2018 0:19
Reporter: Klaus Habel Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:6.3.9.0 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:x86
Tags: libcairo. dll 1.10.2.0

[17 Apr 2018 16:34] Klaus Habel
Description:
While modeling a database using EER Diagram I tried to fill text into a new text object I received the message "Eine externe Komponente hat eine Ausnahme ausgelöst" (external component has thrown an exception).

After this I couldn't go on editing the EER Diagram - I permanently receive the above mentioned message. Also I couldn't print or export the model. When continuing to edit the diagram the workbench chrashed.

Otherwise editing within the tab "MySQL Model" is still possible.

Windows eventlog has shown the following messages (therefore I think there is a problem with the libcairo.dll):

Anwendung: MySQLWorkbench.exe
Frameworkversion: v4.0.30319
Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet.
Ausnahmeinformationen: System.AccessViolationException
   bei <Module>.mdc.CanvasView.repaint(mdc.CanvasView*, Int32, Int32, Int32, Int32)
   bei MySQL.GUI.Mdc.WindowsCanvasViewerPanel.OnPaint(System.Windows.Forms.PaintEventArgs)
   bei System.Windows.Forms.Control.PaintWithErrorHandling(System.Windows.Forms.PaintEventArgs, Int16)
   bei System.Windows.Forms.Control.WmPaint(System.Windows.Forms.Message ByRef)
   bei System.Windows.Forms.Control.WndProc(System.Windows.Forms.Message ByRef)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr, Int32, IntPtr, IntPtr)

Name der fehlerhaften Anwendung: MySQLWorkbench.exe, Version: 6.3.9.0, Zeitstempel: 0x5894eb61
Name des fehlerhaften Moduls: libcairo.dll, Version: 1.10.2.0, Zeitstempel: 0x57cfe02d
Ausnahmecode: 0xc0000005
Fehleroffset: 0x000000000007069c
ID des fehlerhaften Prozesses: 0x1ea4
Startzeit der fehlerhaften Anwendung: 0x01d3d5d83af8911f
Pfad der fehlerhaften Anwendung: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\MySQLWorkbench.exe
Pfad des fehlerhaften Moduls: C:\Program Files\MySQL\MySQL Workbench 6.3 CE\libcairo.dll
Berichtskennung: e59e6c40-2614-4f76-9b51-e7c63a07203a
Vollständiger Name des fehlerhaften Pakets: 
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 

Sorry this text is in German.

The WB logfile show the following error:

[ERR][      Workbench]: Eine externe Komponente hat eine Ausnahme ausgelöst.
Exception = System.Runtime.InteropServices.SEHException
Message = Eine externe Komponente hat eine Ausnahme ausgelöst.
FullText = System.Runtime.InteropServices.SEHException (0x80004005): Eine externe Komponente hat eine Ausnahme ausgelöst.
   bei wbprint.printPageHDC(Ref<model_Diagram>* , Int32 , HDC__* , Int32 , Int32 )
   bei MySQL.GUI.Workbench.Plugins.Printing.printPageHDC(GrtValue view, Int32 page, ValueType hdc, Int32 width, Int32 height)
   bei MySQL.GUI.Workbench.Plugins.PrintPreviewDialog.printDocument_PrintPage(Object sender, PrintPageEventArgs e)
   bei System.Drawing.Printing.PrintDocument.OnPrintPage(PrintPageEventArgs e)
   bei System.Drawing.Printing.PrintController.PrintLoop(PrintDocument document)
   bei System.Drawing.Printing.PrintController.Print(PrintDocument document)
   bei System.Drawing.Printing.PrintDocument.Print()
   bei System.Windows.Forms.PrintPreviewControl.ComputePreview()
   bei System.Windows.Forms.PrintPreviewControl.CalculatePageInfo()
   bei System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
   bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   bei System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
   bei System.Windows.Forms.Control.InvokeMarshaledCallbacks()

How to repeat:
Whenever I try th edit the EER Diagram of the affected file (30jhrKrieg.mwbd) the exception is thrown when trying to edit EER diagram.
[17 Apr 2018 16:41] Klaus Habel
affected file

Attachment: 30jhrKrieg.mwb (application/octet-stream, text), 35.54 KiB.

[17 Apr 2018 16:43] MySQL Verification Team
Please try version 6.3.10. Thanks.
[17 Apr 2018 17:19] Klaus Habel
After installation of version 6.3.10 the problem persited - same behavior.
[17 Apr 2018 17:57] MySQL Verification Team
Thank you for the feedback. Duplicate of https://bugs.mysql.com/bug.php?id=87430.
[18 Apr 2018 0:19] Klaus Habel
After using the menu option "Model -> Create Diagram from Catalog Objects" I only lost the text fields but now I can gon on modeling the database. Therefore I change the severity of this problem.