Bug #90390 TableAdapter generator problem
Submitted: 11 Apr 2018 18:06 Modified: 2 Jul 2019 19:01
Reporter: Bartosz Nowicki Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Visual Studio Integration Severity:S1 (Critical)
Version:1.2.7 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[11 Apr 2018 18:06] Bartosz Nowicki
Description:
With new version of Visual Studio 2017 v15.6.6
there is huge problem: generator of adapters doesn't work

http://ab.getin.ovh/mysql/screen1.png

Work with new and old projects using MySQL integration is imposible!

How to repeat:
create new WinForm project, Create new data set, Define new connection to mysql server and try add new tableadapter to dataset finish with error:
Object reference not set to an instance of an object.

like on screen:
http://ab.getin.ovh/mysql/screen1.png
[11 Apr 2018 18:09] Bartosz Nowicki
Screenshot with error

Attachment: screen1.png (image/png, text), 18.28 KiB.

[13 Apr 2018 7:41] Chiranjeevi Battula
Hello Bartosz Nowicki,

Thank you for the bug report.
Verified this behavior on Visual Studio 2017 (C#.Net) and Connector/NET 6.10.6 version.

Thanks,
Chiranjeevi.
[13 Apr 2018 7:41] Chiranjeevi Battula
Screenshot

Attachment: Bug_90390.PNG (image/png, text), 15.92 KiB.

[17 Jul 2018 0:47] Don VonderBurg
I get the same error with the same screen shots.

Using 
Visual Studio 2017 Pro 15.7.5
MySQL for Visual Studio 2017 Version 2.0.5
MySQL Connector .Net 8.0.11

I've used the MySQL Installer and tried installing manually, neither work. I also tried .Net connector version 6.9.12. Project is c# .Net 4.6.2.
[27 Jul 2018 6:27] Jeremy Leigh
Why can mysql never get it right? every time they are breaking things.
[22 Aug 2018 12:05] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=92123 marked as duplicate of this one.
[24 Oct 2018 8:25] John McDonald
This is a major issue for me too.
[2 Jul 2019 19:01] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL for Visual Studio 1.2.9 release, and here's the changelog entry:

The TableAdapter Configuration Wizard in Visual Studio configured with a
valid MySQL connection produced an error, instead of generating the
expected TableAdapter. Now, the error condition is resolved when MySQL
Connector/NET 6.10.8 (or higher) or MySQL Connector/NET 8.0.14 (or higher)
are available for use by MySQL for Visual Studio.

Thank you for the bug report.