Bug #90356 Cannot Alter table from workbench
Submitted: 9 Apr 2018 21:39 Modified: 9 Apr 2018 22:24
Reporter: Rob Reynolds Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S5 (Performance)
Version:6.3.10 OS:Microsoft Windows (Microsoft Windows 10 Enterprise)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[9 Apr 2018 21:39] Rob Reynolds
Description:
If there is a 'virtual' column that exist in a table, the alter table screen does not show all of the fields that are after this column. In addition, the UI will not show any of the Indexes.

How to repeat:
create a table with a few columns, create two specific columns.

#1 'email_address' - varchar, latin1_swedish_ci,

#1 'email_domain' - varchar, latin1_swedish_ci,STORED GENERATED, VIRTUAL: substr(`to_email_address`,(1 + locate('@',`to_email_address`)))

Suggested fix:
handle virtual columns in the UI :)
[9 Apr 2018 21:40] Rob Reynolds
VIRTUAL: substr(`email_address`,(1 + locate('@',`email_address`)))
[9 Apr 2018 22:24] MySQL Verification Team
Duplicate of bug https://bugs.mysql.com/bug.php?id=90350. Thanks.