Bug #89386 Index pages of YUM repos is not current
Submitted: 24 Jan 2018 15:39 Modified: 11 Jun 2019 15:07
Reporter: Daniel Holmes Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Package Repos and Docker Images Severity:S2 (Serious)
Version: OS:Red Hat
Assigned to: MySQL Verification Team CPU Architecture:Any

[24 Jan 2018 15:39] Daniel Holmes
Description:
The generated index files for these repos are not current.  Specifically, this RPM file
repo.mysql.com/yum/mysql-5.7-community/el/7/x86_64/mysql-community-common-5.7.21-1.el7.x86_64.rpm

is posted but not listed on the index page 
repo.mysql.com/yum/mysql-5.7-community/el/7/x86_64/

This is preventing our environment from being able to mirror in a copy of the RPM.  

How to repeat:
Verify the index URL inthe description and see that the mysql-community-common-5.7.21-1.el7.x86_64.rpm is not in the listing.

Suggested fix:
Please regenerate the index files to be accurate.

Bonus: If rsync could be enabled on repo.mysql.com that would be even better so that we could rsync the mirror rather than having to depend on a web crawl method.  This is necessary in our environment because we need to push a mirror to an area of our network that does not have direct internet access available.
[24 Jan 2018 16:43] Terje Røsten
Hi!

This is due to limitation in content delivery network (CDN),
I think you can use a tool that understand repo meta data to
keep a local mirror current, search for e.g. reposync & 
createrepo.
[24 Jan 2018 16:52] Daniel Holmes
Yes, I do know about reposync as a tool.  Problem with that is needing to configure an overall repo file to cover each of the repos in your overall site and then it doesn't pick up new versions when they might appear without having to edit and maintain that repo file.  That is a reason that an rsync solution would be better.

I understand the point about the CDN, but would that explain that the RPM is available on the site but the index file is not updated?
[11 Jun 2019 15:07] MySQL Verification Team
Hi,

Edge servers are caching this directory listing for too long. We did contact the CDN to see if TTL can be reduced for those directory listings but is really not much we can do about it other than that.

Thanks
Bogdan
[23 Jul 2019 13:50] MySQL Verification Team
Bug 96174 is marked as duplicate of this bug

p.s. TTL on these are now set to 15min