Bug #89374 Mysql Stoped Frequently
Submitted: 24 Jan 2018 9:17 Modified: 24 Jan 2018 9:38
Reporter: Haris Lukman Hakim Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:Mysql57 OS:Microsoft Windows (Windows Server 2012)
Assigned to: CPU Architecture:Any

[24 Jan 2018 9:17] Haris Lukman Hakim
Description:
Timestamp, Thread, Type, Details
, , , Version: '5.7.11-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
2018-01-24T08:13:05, 0, ERROR, InnoDB: Operating system error number 995 in a file operation.
2018-01-24T08:13:05, 0, ERROR, InnoDB: The error means that the I/O operation has been aborted because of either a thread exit or an application request. Retry attempt is made.
, , , 2018-01-24 15:13:05 0x178  InnoDB: Assertion failure in thread 376 in file fil0fil.cc line 5789
, , , InnoDB: Failing assertion: err == DB_SUCCESS
, , , InnoDB: We intentionally generate a memory trap.
, , , InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
, , , InnoDB: If you get repeated assertion failures or crashes, even
, , , InnoDB: immediately after the mysqld startup, there may be
, , , InnoDB: corruption in the InnoDB tablespace. Please refer to
, , , InnoDB: http://dev.mysql.com/doc/refman/5.7/en/forcing-innodb-recovery.html
, , , InnoDB: about forcing recovery.
, , , 08:13:05 UTC - mysqld got exception 0x80000003 ;
, , , This could be because you hit a bug. It is also possible that this binary
, , , or one of the libraries it was linked against is corrupt, improperly built,
, , , or misconfigured. This error can also be caused by malfunctioning hardware.
, , , Attempting to collect some information that could help diagnose the problem.
, , , As this is a crash and something is definitely wrong, the information
, , , collection process might fail.
, , , key_buffer_size=8388608
, , , read_buffer_size=65536
, , , max_used_connections=34
, , , max_threads=151
, , , thread_count=7
, , , connection_count=7
, , , It is possible that mysqld could use up to
, , , key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 58345 K  bytes of memory
, , , Hope that's ok; if not, decrease some variables in the equation.
, , , Thread pointer: 0x0
, , , Attempting backtrace. You can use the following information to find out
, , , where mysqld died. If you see no messages after this, something went
, , , terribly wrong...
, , , 7f7d9d75ea2    mysqld.exe!my_errno()
, , , 7f7da119919    mysqld.exe!my_wildcmp_mb()
, , , 7f7da118810    mysqld.exe!my_wildcmp_mb()
, , , 7f7d9e75ac8    mysqld.exe!?reserve@?$vector@EV?$allocator@E@std@@@std@@QEAAX_K@Z()
, , , 7f7d9e9c49a    mysqld.exe!?reserve@?$vector@EV?$allocator@E@std@@@std@@QEAAX_K@Z()
, , , 7f7d9e34e94    mysqld.exe!?reserve@?$vector@EV?$allocator@E@std@@@std@@QEAAX_K@Z()
, , , 7f9acd41842    KERNEL32.DLL!BaseThreadInitThunk()
, , , 7f9af5ac3f1    ntdll.dll!RtlUserThreadStart()
, , , The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
, , , information that should help you find out what is causing the crash.
2018-01-24T08:15:17, 0, Note, C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe (mysqld 5.7.11-log) starting as process 4452 ...
2018-01-24T08:15:17, 0, Note, InnoDB: Mutexes and rw_locks use Windows interlocked functions
2018-01-24T08:15:17, 0, Note, InnoDB: Uses event mutexes
2018-01-24T08:15:17, 0, Note, InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
2018-01-24T08:15:17, 0, Note, InnoDB: Compressed tables use zlib 1.2.3
2018-01-24T08:15:17, 0, Note, InnoDB: Adjusting innodb_buffer_pool_instances from 8 to 1 since innodb_buffer_pool_size is less than 1024 MiB
2018-01-24T08:15:17, 0, Note, InnoDB: Number of pools: 1
2018-01-24T08:15:17, 0, Note, InnoDB: Not using CPU crc32 instructions
2018-01-24T08:15:17, 0, Note, InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2018-01-24T08:15:17, 0, Note, InnoDB: Completed initialization of buffer pool
2018-01-24T08:15:17, 0, Note, InnoDB: Highest supported file format is Barracuda.
2018-01-24T08:15:17, 0, Note, InnoDB: Log scan progressed past the checkpoint lsn 96307764083
2018-01-24T08:15:17, 0, Note, InnoDB: Doing recovery: scanned up to log sequence number 96307764092
2018-01-24T08:15:17, 0, Note, InnoDB: Doing recovery: scanned up to log sequence number 96307764092
2018-01-24T08:15:17, 0, Note, InnoDB: Database was not shutdown normally!
2018-01-24T08:15:17, 0, Note, InnoDB: Starting crash recovery.
2018-01-24T08:15:19, 0, Note, InnoDB: Removed temporary tablespace data file: "ibtmp1"
2018-01-24T08:15:19, 0, Note, InnoDB: Creating shared tablespace for temporary tables
2018-01-24T08:15:19, 0, Note, InnoDB: Setting file '.\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2018-01-24T08:15:20, 0, Note, InnoDB: File '.\ibtmp1' size is now 12 MB.
2018-01-24T08:15:20, 0, Note, InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.
2018-01-24T08:15:20, 0, Note, InnoDB: 32 non-redo rollback segment(s) are active.
2018-01-24T08:15:20, 0, Note, InnoDB: Waiting for purge to start
2018-01-24T08:15:20, 0, Note, InnoDB: 5.7.11 started; log sequence number 96307764092
2018-01-24T08:15:20, 0, Note, InnoDB: Loading buffer pool(s) from C:\ProgramData\MySQL\MySQL Server 5.7\Data\ib_buffer_pool
2018-01-24T08:15:20, 0, Note, Plugin 'FEDERATED' is disabled.
2018-01-24T08:15:20, 0, Note, InnoDB: Buffer pool(s) load completed at 180124 15:15:20
2018-01-24T08:15:20, 0, Warning, Failed to set up SSL because of the following SSL library error: SSL context is not usable without certificate and private key
2018-01-24T08:15:20, 0, Note, Server hostname (bind-address): '*'; port: 3306
2018-01-24T08:15:20, 0, Note, IPv6 is available.
2018-01-24T08:15:20, 0, Note, - '::' resolves to '::';
2018-01-24T08:15:20, 0, Note, Server socket created on IP: '::'.
2018-01-24T08:15:20, 0, Note, Event Scheduler: Loaded 0 events
2018-01-24T08:15:20, 0, Note, C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe: ready for connections.

How to repeat:
Timestamp, Thread, Type, Details
, , , Version: '5.7.11-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
2018-01-24T08:13:05, 0, ERROR, InnoDB: Operating system error number 995 in a file operation.
2018-01-24T08:13:05, 0, ERROR, InnoDB: The error means that the I/O operation has been aborted because of either a thread exit or an application request. Retry attempt is made.
, , , 2018-01-24 15:13:05 0x178  InnoDB: Assertion failure in thread 376 in file fil0fil.cc line 5789
, , , InnoDB: Failing assertion: err == DB_SUCCESS
, , , InnoDB: We intentionally generate a memory trap.
, , , InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
, , , InnoDB: If you get repeated assertion failures or crashes, even
, , , InnoDB: immediately after the mysqld startup, there may be
, , , InnoDB: corruption in the InnoDB tablespace. Please refer to
, , , InnoDB: http://dev.mysql.com/doc/refman/5.7/en/forcing-innodb-recovery.html
, , , InnoDB: about forcing recovery.
, , , 08:13:05 UTC - mysqld got exception 0x80000003 ;
, , , This could be because you hit a bug. It is also possible that this binary
, , , or one of the libraries it was linked against is corrupt, improperly built,
, , , or misconfigured. This error can also be caused by malfunctioning hardware.
, , , Attempting to collect some information that could help diagnose the problem.
, , , As this is a crash and something is definitely wrong, the information
, , , collection process might fail.
, , , key_buffer_size=8388608
, , , read_buffer_size=65536
, , , max_used_connections=34
, , , max_threads=151
, , , thread_count=7
, , , connection_count=7
, , , It is possible that mysqld could use up to
, , , key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 58345 K  bytes of memory
, , , Hope that's ok; if not, decrease some variables in the equation.
, , , Thread pointer: 0x0
, , , Attempting backtrace. You can use the following information to find out
, , , where mysqld died. If you see no messages after this, something went
, , , terribly wrong...
, , , 7f7d9d75ea2    mysqld.exe!my_errno()
, , , 7f7da119919    mysqld.exe!my_wildcmp_mb()
, , , 7f7da118810    mysqld.exe!my_wildcmp_mb()
, , , 7f7d9e75ac8    mysqld.exe!?reserve@?$vector@EV?$allocator@E@std@@@std@@QEAAX_K@Z()
, , , 7f7d9e9c49a    mysqld.exe!?reserve@?$vector@EV?$allocator@E@std@@@std@@QEAAX_K@Z()
, , , 7f7d9e34e94    mysqld.exe!?reserve@?$vector@EV?$allocator@E@std@@@std@@QEAAX_K@Z()
, , , 7f9acd41842    KERNEL32.DLL!BaseThreadInitThunk()
, , , 7f9af5ac3f1    ntdll.dll!RtlUserThreadStart()
, , , The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
, , , information that should help you find out what is causing the crash.
2018-01-24T08:15:17, 0, Note, C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe (mysqld 5.7.11-log) starting as process 4452 ...
2018-01-24T08:15:17, 0, Note, InnoDB: Mutexes and rw_locks use Windows interlocked functions
2018-01-24T08:15:17, 0, Note, InnoDB: Uses event mutexes
2018-01-24T08:15:17, 0, Note, InnoDB: _mm_lfence() and _mm_sfence() are used for memory barrier
2018-01-24T08:15:17, 0, Note, InnoDB: Compressed tables use zlib 1.2.3
2018-01-24T08:15:17, 0, Note, InnoDB: Adjusting innodb_buffer_pool_instances from 8 to 1 since innodb_buffer_pool_size is less than 1024 MiB
2018-01-24T08:15:17, 0, Note, InnoDB: Number of pools: 1
2018-01-24T08:15:17, 0, Note, InnoDB: Not using CPU crc32 instructions
2018-01-24T08:15:17, 0, Note, InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2018-01-24T08:15:17, 0, Note, InnoDB: Completed initialization of buffer pool
2018-01-24T08:15:17, 0, Note, InnoDB: Highest supported file format is Barracuda.
2018-01-24T08:15:17, 0, Note, InnoDB: Log scan progressed past the checkpoint lsn 96307764083
2018-01-24T08:15:17, 0, Note, InnoDB: Doing recovery: scanned up to log sequence number 96307764092
2018-01-24T08:15:17, 0, Note, InnoDB: Doing recovery: scanned up to log sequence number 96307764092
2018-01-24T08:15:17, 0, Note, InnoDB: Database was not shutdown normally!
2018-01-24T08:15:17, 0, Note, InnoDB: Starting crash recovery.
2018-01-24T08:15:19, 0, Note, InnoDB: Removed temporary tablespace data file: "ibtmp1"
2018-01-24T08:15:19, 0, Note, InnoDB: Creating shared tablespace for temporary tables
2018-01-24T08:15:19, 0, Note, InnoDB: Setting file '.\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2018-01-24T08:15:20, 0, Note, InnoDB: File '.\ibtmp1' size is now 12 MB.
2018-01-24T08:15:20, 0, Note, InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.
2018-01-24T08:15:20, 0, Note, InnoDB: 32 non-redo rollback segment(s) are active.
2018-01-24T08:15:20, 0, Note, InnoDB: Waiting for purge to start
2018-01-24T08:15:20, 0, Note, InnoDB: 5.7.11 started; log sequence number 96307764092
2018-01-24T08:15:20, 0, Note, InnoDB: Loading buffer pool(s) from C:\ProgramData\MySQL\MySQL Server 5.7\Data\ib_buffer_pool
2018-01-24T08:15:20, 0, Note, Plugin 'FEDERATED' is disabled.
2018-01-24T08:15:20, 0, Note, InnoDB: Buffer pool(s) load completed at 180124 15:15:20
2018-01-24T08:15:20, 0, Warning, Failed to set up SSL because of the following SSL library error: SSL context is not usable without certificate and private key
2018-01-24T08:15:20, 0, Note, Server hostname (bind-address): '*'; port: 3306
2018-01-24T08:15:20, 0, Note, IPv6 is available.
2018-01-24T08:15:20, 0, Note, - '::' resolves to '::';
2018-01-24T08:15:20, 0, Note, Server socket created on IP: '::'.
2018-01-24T08:15:20, 0, Note, Event Scheduler: Loaded 0 events
2018-01-24T08:15:20, 0, Note, C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe: ready for connections.
[24 Jan 2018 9:38] Miguel Solorzano
Thank you for taking the time to report a problem.  Unfortunately you
are not using a current version of the product you reported a problem
with -- the problem might already be fixed. Please download
a new version from http://www.mysql.com/downloads/.

Also, there is no test case provided in the bug report and hence there
is nothing we can verify here.  If you are able to reproduce the bug
with one of the latest versions, please attach the exact reproducible
test case and change the version on this bug report to the version you
tested and change the status back to "Open".  Again, thank you for your
continued support of MySQL.