Bug #89373 -DWITH_ZLIB=system broken
Submitted: 24 Jan 2018 8:46 Modified: 21 Mar 2018 15:03
Reporter: Laurynas Biveinis (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S2 (Serious)
Version:8.0.4 OS:Any
Assigned to: CPU Architecture:Any
Tags: cmake, regression, zlib

[24 Jan 2018 8:46] Laurynas Biveinis
Description:
8.0.4 broke -DWITH_ZLIB=system.

How to repeat:
$ cmake ../mysql-server/ -DWITH_ZLIB=system -DWITH_BOOST=~/mysql-boost -DDOWNLOAD_BOOST=ON -DENABLE_DOWNLOADS=ON
...
$ make
...
/usr/bin/ld.gold: error: cannot find -lzlib
/home/laurynas/mysql-server/unittest/gunit/innodb/lob/zlob0int.cc:624: error: undefined reference to 'inflateInit_'
/home/laurynas/mysql-server/unittest/gunit/innodb/lob/zlob0int.cc:647: error: undefined reference to 'inflate'
/home/laurynas/mysql-server/unittest/gunit/innodb/lob/zlob0int.cc:662: error: undefined reference to 'inflateEnd'
/home/laurynas/mysql-server/unittest/gunit/innodb/lob/zlob0int.cc:637: error: undefined reference to 'inflate'
/home/laurynas/mysql-server/unittest/gunit/innodb/lob/zlob0int.cc:488: error: undefined reference to 'deflateInit_'
/home/laurynas/mysql-server/unittest/gunit/innodb/lob/zlob0int.cc:497: error: undefined reference to 'deflateBound'
/home/laurynas/mysql-server/unittest/gunit/innodb/lob/zlob0int.cc:504: error: undefined reference to 'deflate'
/home/laurynas/mysql-server/unittest/gunit/innodb/lob/zlob0int.cc:520: error: undefined reference to 'deflateEnd'
collect2: error: ld returned 1 exit status
unittest/gunit/innodb/lob/CMakeFiles/ut0frags.dir/build.make:250: recipe for target 'unittest/gunit/innodb/lob/ut0frags' failed
make[2]: *** [unittest/gunit/innodb/lob/ut0frags] Error 1
CMakeFiles/Makefile2:16345: recipe for target 'unittest/gunit/innodb/lob/CMakeFiles/ut0frags.dir/all' failed
make[1]: *** [unittest/gunit/innodb/lob/CMakeFiles/ut0frags.dir/all] Error 2

Building with -DWITH_ZLIB=bundled succeeds.
[24 Jan 2018 10:17] Umesh Shastry
Hello Laurynas,

Thank you for the report and feedback.

Thanks,
Umesh
[25 Jan 2018 10:36] Laurynas Biveinis
Bug 89400 is duplicate
[25 Jan 2018 10:43] Umesh Shastry
Bug #89400 marked as duplicate of this one
[26 Jan 2018 14:30] Tor Didriksen
Posted by developer:
 
Fixed by

commit c54c4aeac51c3d002b9cddb1f81a0626a6b06b82
Author: Tor Didriksen <tor.didriksen@oracle.com>
Date:   Mon Dec 11 14:34:29 2017 +0100

    WL#8960 - InnoDB: Partial Update of Large Objects (BLOBs)
    
    Post-push fix: broken cmake code for -DWITH_ZLIB=system
[21 Mar 2018 15:03] Paul Dubois
Posted by developer:
 
Fixed in 8.0.11.

Configuring with -DWITH_ZLIB=system resulted in a linker error.