Bug #89372 Using --no-dd-upgrade seems to have no effect
Submitted: 24 Jan 2018 8:45 Modified: 8 May 2018 8:25
Reporter: Geert Vanderkelen Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Data Dictionary Severity:S3 (Non-critical)
Version:8.0.4 OS:Debian (9.3)
Assigned to: CPU Architecture:Any
Tags: upgrade

[24 Jan 2018 8:45] Geert Vanderkelen
Description:
Upgrade RC is not supported, but the change log of 8.0.4 mentions the new option --no-dd-upgrade which would indicate that MySQL Team considered this issue:

2018-01-24T08:43:07.474046Z 0 [System] [MY-010116] /usr/sbin/mysqld (mysqld 8.0.4-rc-log) starting as process 24392 ...
2018-01-24T08:43:07.573125Z 1 [ERROR] [MY-011096] No data dictionary version number found.
2018-01-24T08:43:07.573787Z 0 [ERROR] [MY-010020] Data Dictionary initialization failed.
2018-01-24T08:43:07.573831Z 0 [ERROR] [MY-010119] Aborting

How to repeat:

When upgrading MySQL 8.0.3-rc to 8.0.4-rc, it fails with:
  [ERROR] [MY-010020] Data Dictionary initialization failed.

Using the new option --no-dd-upgrade (in systemd or outside):

# su - mysql -c "/usr/sbin/mysqld --pid-file=/var/run/mysqld/mysqld.pid --no-dd-upgrade"

Error MY-011096 is still reported, and we can not upgrade.
[5 Mar 2018 15:19] Bogdan Kecman
Hey Geert,

What version are you upgrading from?

all best
Bogdan
[4 Apr 2018 19:16] Geert Vanderkelen
(Oops, email got spammed out :( )

Hi Bogdan,

Like mentioned in 'How to Repeat': MySQL 8.0.3-rc to 8.0.4-rc
[4 Apr 2018 23:31] Bogdan Kecman
Sorry Geert kill me if I can explain how I did not see that :(

testing now :D

all best
b.
[5 May 2018 1:48] Bogdan Kecman
Sorry for the late reply, verified as described

kind regards
Bogdan
[7 May 2018 6:48] Ståle Deraas
Posted by developer:
 
In the preparations to support upgrade in GA is parts are pushed to the RC. But upgrading from RCs is still not supported. So this is still "not a bug".
[10 Dec 2018 9:30] Jonathan Endy
By mistake, I've started 8.0.3 files with 8.0.13 service.

The 8.0.3 not starting claiming redo log is 8.0.13 and Failed to initialize DD Storage Engine.

Is it possible to recover from that error? I don't have a backup ):