Bug #89227 Mysql for Visual studio cant install in visual studio 2017 community updated
Submitted: 14 Jan 2018 22:45 Modified: 18 Jan 2018 17:29
Reporter: Arnold Anka Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Visual Studio Integration Severity:S1 (Critical)
Version:1.2.7 and 2.0.5 OS:Microsoft Windows (7 pro)
Assigned to: CPU Architecture:Any
Tags: mysql for visual studio

[14 Jan 2018 22:45] Arnold Anka
Description:
Im unable to install mysql for visual studio version 1.2.7 or 2.0.5 in visual studio 2017 community.
Im running win 7 pro.
First .net 4.7. Backrolled to 4.61. Still no luck.
Clean installed visual studio. No luck.
If i run typical the install rollback from about 92-93%.
I have searched the net the whole weekend and tried multiple solutions and reinstalls with no luck. 
Totaly stuck with this and  really dont want to select sql server instead.

How to repeat:
Install latest visual studio on win 7 pro.
Install mysql for visual studio.

Doesnt mather if you have connector before or mysql full och developer. Will not work any way.
[15 Jan 2018 5:02] Chiranjeevi Battula
Hello Arnold Anka,

Thank you for the bug report.
This is most likely duplicate of Bug #85908, please see Bug #85908

Thanks,
Chiranjeevi.
[15 Jan 2018 7:29] Arnold Anka
Its not a duplicate of the former bug since this concerns 1.2.7 and 2.0.5.

I have tried everything in that thread. And its not the same error message.
[16 Jan 2018 7:31] Chiranjeevi Battula
Hello Arnold Anka,

Thank you for your feedback.
I could not repeat the issues while installing the MySQL Visual Studio Integration 1.2.7 and 2.0.5 versions.
If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Thanks,
Chiranjeevi.
[18 Jan 2018 17:29] Arnold Anka
Now I have cleaninstalled windows 7 pro with sp1.
Then visual studio. All 3 C# packages.

Same thing.

Just wont work to install. Please help. 
We will have to select sql instead which I just dont want if I cant get this to work.

Can you tell me where the log file for the install is? Can you tell what is demamded for mysql for windows to install?

I know it is the Visual Studio Integration that wont work. What is needed for this to work?
[25 Jan 2018 23:48] Michael Ahrndt
have you tried this:
https://bugs.mysql.com/bug.php?id=85908
"
After 5 full work days and a reinstall of win 7 pro sp1 i finaly got it working. EF 5 and connector 6.9.9. Not EF 6 though yet.

No real help from mysql team, thanks for that... This bug is a project killer so its bad if its not solved soon.

This is what finaly did it. (thanks to writers above and other forums that gave clues)

1 move %localappdata%\Microsoft\VisualStudio\<config>\privateregistry.bin
2 dont login to visual.
3 install 1.2.7 mysql for visual studio
4 install connector 6.9.9
5 put the privateregistry.bin back

I used mysql-installer-community-5.7.17.0 to get the 6.9.9 connector net.
mysql-installer-web-community-5.7.20.0 to get the 1.2.7 mysql for visual studio

Then it will work with EF 5.
I also created the /setup/vs keys but dont think it made any difference. Just saying if anyone have the same problem.

Connectors above 6.9.9 just wont work with community edition.

Since this file is where devenv reads the user regestry the problem most likely is that the installer only reads the register where older visual wrote the keys.
So when the mysql team tries to replicate they have the old keys in the register i guess.

If someone at mysql team bother to read this i think it will make sence to start here.

I hope this helps other developers.

"

or tried this with the MSI installers: 
http://wixtoolset.org/documentation/manual/v3/howtos/general/get_a_log.html
to be able to post a bug report here?

Thanks
Mike
[25 Jan 2018 23:50] Michael Ahrndt
here is the relevant download link for v. 6.9.9
https://downloads.mysql.com/archives/c-net/
[29 Jan 2018 6:21] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=89426 marked as duplicate of this one.