Bug #89062 when i use symi slave i find an problem 。
Submitted: 27 Dec 2017 7:08 Modified: 10 Jan 2018 2:54
Reporter: Minglei Qin Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:mysql Ver 14.14 Distrib 5.7.19, for Lin OS:CentOS (CentOS release 6.9 (Final))
Assigned to: Bogdan Kecman CPU Architecture:Any

[27 Dec 2017 7:08] Minglei Qin
Description:
when i use symi slave i find an problem 。when i restart slave mysql :
find information in the master 
+-------+----------+-----------------+------+------------------+--------+---------------------------------------------------------------+------------------+
| Id    | User     | Host            | db   | Command          | Time   | State                                                         | Info             |
+-------+----------+-----------------+------+------------------+--------+---------------------------------------------------------------+------------------+
|  6373 | repl     | host_db_3:64391 | NULL | Binlog Dump GTID | 505165 | Master has sent all binlog to slave; waiting for more updates | NULL             |
| 22033 | test     | host_db_2:24393 | ppp  | Sleep            |      0 |                                                               | NULL             |
| 22732 | repl     | host_db_1:36430 | NULL | Killed           |   3422 | Waiting to finalize termination                               | NULL             |
| 22745 | repl     | host_db_1:36450 | NULL | Binlog Dump GTID |   2218 | Waiting to finalize termination                               | NULL             |
| 22746 | repl     | host_db_1:36452 | NULL | Binlog Dump GTID |   2098 | Waiting to finalize termination                               | NULL             |
| 22748 | repl     | host_db_1:36456 | NULL | Binlog Dump GTID |   1986 | Waiting to finalize termination       

but not kill ;
and information of error of the master:
2017-12-26T03:00:33.766297Z 22068 [Note] Aborted connection 22068 to db: 'ppp' user: 'root' host: 'localhost' (Got an error writing communication packets)
2017-12-26T05:45:50.285956Z 0 [ERROR] /usr/sbin/mysqld: Got an error reading communication packets
2017-12-26T05:45:52.000807Z 21958 [ERROR] Semi-sync master failed on net_flush() before waiting for slave reply
2017-12-26T05:45:52.006351Z 21958 [Note] Stop semi-sync binlog_dump to slave (server_id: 2221)
ump thread(21958).
2017-12-26T05:45:58.923553Z 22073 [Note] Start binlog_dump to master_thread_id(22073) slave_server(2221), pos(, 4)
ump thread(21958).
2017-12-26T05:46:58.971391Z 22074 [Note] Start binlog_dump to master_thread_id(22074) slave_server(2221), pos(, 4)
ump thread(21958).
2017-12-26T05:48:59.032633Z 22075 [Note] Start binlog_dump to master_thread_id(22075) slave_server(2221), pos(, 4)
ump thread(21958).
2017-12-26T05:50:59.093838Z 22076 [Note] Start binlog_dump to master_thread_id(22076) slave_server(2221), pos(, 4)
ump thread(21958).

017-12-27T00:01:58.696954Z 22632 [Note] Start binlog_dump to master_thread_id(22632) slave_server(2221), pos(, 4)
2017-12-27T00:03:55.000802Z 22240 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.000825Z 22485 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.000835Z 22543 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.001389Z 22214 [Note] Aborted connection 22214 to db: 'unconnected' user: 'repl' host: 'host_db_1' (failed on flush_net())
2017-12-27T00:03:55.001549Z 22609 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.001650Z 22426 [Note] Aborted connection 22426 to db: 'unconnected' user: 'repl' host: 'host_db_1' (failed on flush_net())
2017-12-27T00:03:55.001725Z 22510 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.001732Z 22392 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.002245Z 22479 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.002271Z 22500 [Note] Aborted connection 22500 to db: 'unconnected' user: 'repl' host: 'host_db_1' (failed on flush_net())
2017-12-27T00:03:55.002247Z 22586 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.002394Z 22482 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.002488Z 22613 [Note] Start semi-sync binlog_dump to slave (server_id: 2221), pos(, 4)
2017-12-27T00:03:55.002579Z 0 [ERROR] /usr/sbin/mysqld: Got an error reading communication packets
2017-12-27T00:03:55.002590Z 0 [ERROR] /usr/sbin/mysqld: Got an error reading communication packets
2017-12-27T00:03:55.002592Z 0 [ERROR] /usr/sbin/mysqld: Got an error reading communication packets
2017-12-27T00:03:55.002594Z 0 [ERROR] /usr/sbin/mysqld: Got an error reading communication packets
2017-12-27T00:03:55.002597Z 0 [ERROR] /usr/sbin/mysqld: Got an error reading communication packets
2017-12-27T00:03:55.002599Z 0 [ERROR] /usr/sbin/mysqld: Got an error reading communication packets
2017-12-27T00:03:55.002601Z 0 [ERROR] /usr/sbin/mysqld: Got an error reading communication packets
2017-12-27T00:03:55.002603Z 0 [ERROR] /usr/sbin/mysqld: Got an error reading communication packets

but when i user no-symi slave this problem is reslove。

How to repeat:
on the master:
set global rpl_semi_sync_master_enabled=on;
on the slave:
stop slave;
 set global rpl_semi_sync_slave_enabled=on;
start slave;

io_threads and sql_threads is ok 。 state is yes
[10 Jan 2018 2:54] Bogdan Kecman
Hi,

I cannot reproduce this issue. What kind of traffic are you running on master when this happens? I tried with traffic and without traffic. Can you reproduce this every time or?

best regards
Bogdan
[10 Aug 2018 10:20] Prasad N
Yes this can be reproduced.
Bug: 90857
[6 Apr 9:34] WANG GUANGYOU
Perhaps  turnning slave_compressed_protocol off  can solve the problem
[30 May 2:40] Prasad N
slave_compressed_protocol is already OFF in our setting