Bug #88962 Specifying multiple comma-separated servers in the connection string fails
Submitted: 18 Dec 2017 17:22 Modified: 19 Dec 2017 6:32
Reporter: John Skrabutenas Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:6.9.8 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: connect replication multiple-server

[18 Dec 2017 17:22] John Skrabutenas
Description:
I get the stack trace below when using a connect string with more than one server name (comma-separated) in the connect string. It appears that this bug was fixed in MySQL Connector/Net 6.7.5 released April 2014 (see bug fix details below). Is is possible that the fix did not make it into the 6.9.x tree? Or were there new problems caused by the previous fix?

StackTrace:
at System.Net.Dns.GetAddrInfo
at System.Net.Dns.InternalGetHostByName
at System.Net.Dns.GetHostEntry
at MySql.Data.Common.MyNetworkStream.GetHostEntry
at MySql.Data.Common.MyNetworkStream.CreateStream
at MySql.Data.Common.StreamCreator.GetTcpStream
at MySql.Data.Common.StreamCreator.GetStream
at MySql.Data.MySqlClient.NativeDriver.Open

Bug fix details:
Configuring replication and load balancing by passing in multiple servers as a comma-separated list to the connection string failed to function. Threading synchronization problems when using replication (specifically when getting a new server/connection) would also sometimes occur. (Bug #19484568, Bug #18112966, Bug #69832)

How to repeat:
Connect using a connect string with multiple servers in it, such as:
"Server=mysqls1,mysqls2;UId=useruser;Pwd=pwdpwd;Database=mydbname"

Suggested fix:
Integrate the fix for the same bug from MySQL Connector/Net 6.7.5
[19 Dec 2017 4:19] Bradley Grainger
This is probably a duplicate of bug #81650.

It's fixed in MySqlConnector: https://github.com/mysql-net/MySqlConnector
[19 Dec 2017 6:32] Chiranjeevi Battula
Hello John Skrabutenas,

Thank you for the bug report.
This is most likely duplicate of Bug #81650, please see Bug #81650

Thanks,
Chiranjeevi.