Bug #8883 mysqld-nt hangs on show tables like "%"
Submitted: 2 Mar 2005 11:27 Modified: 2 Mar 2005 12:31
Reporter: [ name withheld ] Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.0.2 OS:Microsoft Windows (windows 2000)
Assigned to: CPU Architecture:Any

[2 Mar 2005 11:27] [ name withheld ]
Description:
Attempted upgrade from 5.0.0 alpha to 5.0.2 on windows 2000. Succeeded in installing 5.0.2. First test (declare new user) OK. Then tried to work on old data base (imported by moving directory 'bigbase' from mysql5.0.0\data to mysql5.0.2\data ... this is not quite catholic but worked for me before when going from 3.23 to 4.0 from 4.0 to 4.1 and from 4.1 to 5.0.0). Server 5.0.2 starts up ok. Yet any "use bigbase" followed by "show tables" or any select on an existing table ties up the system completely. It isn't even possible anymore to kill the server. I have to shut down windows 2000 completely to get rid of it. 

How to repeat:
As I said: Use win 2000. Use 5.0.2 with a db made in 5.0.0.
[2 Mar 2005 12:31] Victoria Reznichenko
Duplicate for #6950
[2 Mar 2005 12:31] Victoria Reznichenko
Duplicate for #6950