Bug #88735 Primary key is often ignored when updating
Submitted: 1 Dec 2017 23:05 Modified: 7 Dec 2017 16:19
Reporter: Bryce Morrison Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S5 (Performance)
Version:6.3.4 OS:Microsoft Windows (Microsoft Windows 10 Home)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[1 Dec 2017 23:05] Bryce Morrison
Description:
The primary key is sometimes being included in an update statement, but often it is being left out, preventing the values from being modified.

How to repeat:
UPDATE `adventur_vacays`.`listings` SET `airbnbtitle`='Las Vegas 2BR Suite at Desert Rose Resort #01' WHERE ;
UPDATE `adventur_vacays`.`listings` SET `airbnbtitle`='Las Vegas 2BR Suite at Desert Rose Resort #02' WHERE ;

Suggested fix:
Include the key column in the update statement following the WHERE and prior to the semicolon and line-break.
[2 Dec 2017 16:47] Miguel Solorzano
Please try version 6.3.10. Thanks.
[5 Dec 2017 23:39] Bryce Morrison
As requested, I upgraded to version 6.3.10.

The problem is still happening.

The Workbench-generated update script is ending each line with "WHERE ;"
[6 Dec 2017 11:46] Chiranjeevi Battula
Hello Bryce Morrison,

Thank you for the bug report.
I could not repeat the issue at our end using with MySQL workbench 6.3.10 version.
Could you please provide repeatable test case (exact steps, create table scripts, sample table data etc. - please make it as private if you prefer) to confirm this issue at our end?

Thanks,
Chiranjeevi.
[7 Dec 2017 9:49] Chiranjeevi Battula
Hello Bryce Morrison,

Thank you for the feedback.
I could not repeat the issue at our end using with MySQL workbench 6.3.10 version with MySQL 5.7.20 and 5.6.38 versions.
If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Thanks,
Chiranjeevi.
[7 Dec 2017 9:56] Chiranjeevi Battula
Screenshot

Attachment: Bug_88735.PNG (image/png, text), 86.67 KiB.

[7 Dec 2017 16:19] Bryce Morrison
It was not a 100% occurrence, but it did happen on several occasions per day when adjusting the values of just one or two columns across multiple rows (as few as four, and as many as thirty).