Bug #88454 Recovery is not possible with mysqlbinlog.
Submitted: 13 Nov 2017 1:54 Modified: 14 Nov 2017 11:59
Reporter: Katsumasa Yayanagi Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:5.6.19 OS:CentOS (6.5)
Assigned to: CPU Architecture:Any

[13 Nov 2017 1:54] Katsumasa Yayanagi
Description:
I tried to recover from binlog by using mysqlbinlog. However, when using "create temporary table", the following error occurs and I get an error saying "There is no table of Insert destination" and I can not recover it.

Does anyone know of this symptom?

BINLOG's position and file name have tried to restore from the place described in "CHANGE MASTER TO" described in MYSQL DUMP.

[command]
mysqlbinlog - no - defaults XXXX - bin.00987 XXXX - bin.00988 XXXX - bin.00989 [LAST] | mysql - uroot - p

[error]
ERROR 1146 (42S02) at line 2934154: Table 'XXXX_db.WRK_GET_TRANS' does not exist
STOP !!

WRK_GET_TRANS is create temporary table.

How to repeat:
mysqlbinlog - no-defaults XXXX-bin.00987 XXXX-bin.00988 XXXX-bin.00989 [LAST] | mysql - uroot - p
[14 Nov 2017 11:59] Umesh Shastry
Hello Katsumasa,

Thank you for taking the time to report a problem.  Unfortunately you are not using a current version of the product you reported a problem with. MySQL version 5.6.19 is very old and many bugs were fixed since then and the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/

If you are able to reproduce the bug with one of the latest versions(5.6.38, 5.7.20 etc), please change the version on this bug report to the version you tested, provide exact repeatable steps and change the status back to "Open".  Again, thank you for your continued support of MySQL.

I tried to reproduce as described, and even followed exact steps from related Bug #35583 but not seeing any issues with 5.6.38 GA build.

Thanks,
Umesh