Bug #88446 enable mysqld command line arguments via the entrypoint.sh
Submitted: 11 Nov 2017 7:05 Modified: 13 Feb 2018 7:06
Reporter: Spencer Carlson Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Package Repos and Docker Images Severity:S4 (Feature request)
Version:5.7 OS:Any
Assigned to: Lars Tangvald CPU Architecture:Any
Tags: args, arguments, mysqld

[11 Nov 2017 7:05] Spencer Carlson
Description:
Please enable mysqld command line arguments. It would be really nice to be able to change the default port without having to edit the my.cnf file. https://dev.mysql.com/doc/refman/5.7/en/server-options.html

How to repeat:
build and run mysql/mysql-server:5.7

Suggested fix:
Modify the entrypoint.sh file to look for an env variable that contains comma separated command line key value pairs (MYSQLD_OPTS=-P=4222,--port-open-timeout=1000)
[13 Nov 2017 8:43] Lars Tangvald
Hi,

The docker image already supports passing on arguments to the server by simply adding them to the command;

With docker run:
«docker run [...] mysql/mysql-server:5.7 mysqld --port=3307» (note that "mysqld" is optional

Compose:
«command: mysqld --port=3307»
[13 Feb 2018 7:06] Umesh Shastry
Thank you for the report.
Closing as !bg since the requested features are already available.
Also - https://dev.mysql.com/doc/mysql-installation-excerpt/5.7/en/docker-mysql-more-topics.html

Thanks,
Umesh