Bug #87993 Command '[u'net', 'start', 'N49']' returned non-zero exit status 2
Submitted: 5 Oct 2017 14:06 Modified: 28 Oct 2017 22:36
Reporter: vikash tiwari Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S1 (Critical)
Version: OS:Microsoft Windows (10)
Assigned to: Bogdan Kecman CPU Architecture:Any
Tags: cluster

[5 Oct 2017 14:06] vikash tiwari
Description:
I am trying to setup (simple testing) my cluster on one single machine 127.0.0.1. After deployment, once I click on button 'Deploy and start cluster', Cluster never get started, it always provide below message.

"Command '[u'net', 'start', 'N49']' returned non-zero exit status 2"

Please find details below.

Operating System - Windows 10
Cluster version - MySQL Cluster 7.5
Installer version - mysql-cluster-gpl-7.5.7-winx64
Installation path - C:\Users\vtiwari\mysqlc (without any white-space and running as adminstrator)

How to repeat:
I followed simple steps of deployment.

1. Define cluster
2. Define hosts
3. Define processes
4. Define parameters
5. Deploy configuration

On step 5, after deployment, once I click on button 'Deploy and start cluster', Cluster never get started, it always provide below message. No error file is being generated. Only file config.ini and my.cnf (in node 53 & 54) get created and which seems to be right.
[5 Oct 2017 14:08] vikash tiwari
Error message

Attachment: err-2.png (image/png, text), 114.42 KiB.

[7 Oct 2017 0:22] Bogdan Kecman
Hi,

While error is weird (the autoinstaller is work in progress) it happens
 - when you are running as non-admin
 - when you could not start node due to insufficient privileges
 - when you could not start node due to antivirus / firewall / or similar problem
 - when you could not start node due to not enough RAM

for start, right click on setup.bat and "run as administrator", that should solve the problem if everything else is ok.

best regards
Bogdan
[7 Oct 2017 5:38] vikash tiwari
As mentioned earlier, I would like to mention that I am running as administrator and stopped all firewall and antivirus.

Available hard disk capacity - 371 GB
Available RAM - 8 GB

Cluster deployed successfully but unable to start due to same below error. 

"Command '[u'net', 'start', 'N49']' returned non-zero exit status 2"
[7 Oct 2017 12:07] Bogdan Kecman
Can you please look at the logs to see why node is not started. This just shows it was not started and 99% reasons for it to not start are those I gave you. If you are sure those are all good then please get the log uploaded to the bug report.

all best
Bogdan
[9 Oct 2017 5:43] vikash tiwari
Only one file 'config.ini' is being created in node 49. Can you please suggest the location of log file. Does I have to enable creation of log file from somewhere or it would be automatically created.
[10 Oct 2017 4:08] vikash tiwari
Dear Bogdan, 

Looking forward for your comments on my previous comment.

Thank you.
[28 Oct 2017 22:36] Bogdan Kecman
Hi,

freshly installed windows10 and I can't reproduce this problem. It works like a charm. The only requirement is to start setup.bat as Administrator (I find it best to start cmd as administrator and then cd to c:\program files\MySQL\MySQL Cluster 7.5 and then run setup.bat from there)

You can find cluster logs in %USERPROFILE%\MySQL_Cluster\[nodeid]\*.log

best regards
Bogdan
[28 Oct 2017 22:39] Bogdan Kecman
example (freshly installed windows 10, configured "simple testing" on "127.0.0.1", all default settings .. next, next, next, deploy and start.. started)

C:\Users\xxx\MySQL_Cluster>dir
 Volume in drive C has no label.
 Volume Serial Number is 8804-EEA9

 Directory of C:\Users\xxx\MySQL_Cluster

10/28/2017  10:29 PM    <DIR>          .
10/28/2017  10:29 PM    <DIR>          ..
10/28/2017  10:30 PM    <DIR>          1
10/28/2017  10:30 PM    <DIR>          2
10/28/2017  10:30 PM    <DIR>          49
10/28/2017  10:34 PM    <DIR>          53
10/28/2017  10:34 PM    <DIR>          54
               0 File(s)              0 bytes
               7 Dir(s)  63,359,270,912 bytes free

C:\Users\xxx\MySQL_Cluster>dir *.log /s
 Volume in drive C has no label.
 Volume Serial Number is 8804-EEA9

 Directory of C:\Users\xxx\MySQL_Cluster\1

10/28/2017  10:30 PM             8,316 ndb_1_out.log
               1 File(s)          8,316 bytes

 Directory of C:\Users\xxx\MySQL_Cluster\2

10/28/2017  10:30 PM             8,318 ndb_2_out.log
               1 File(s)          8,318 bytes

 Directory of C:\Users\xxx\MySQL_Cluster\49

10/28/2017  10:30 PM               719 ndb_49_cluster.log
10/28/2017  10:30 PM                28 ndb_49_out.log
               2 File(s)            747 bytes

     Total Files Listed:
               4 File(s)         17,381 bytes
               0 Dir(s)  63,359,270,912 bytes free

C:\Users\xxx\MySQL_Cluster>