Bug #87856 CSV export quote-escape regression
Submitted: 25 Sep 2017 15:24 Modified: 7 Mar 2019 3:04
Reporter: Michael Lyons Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:6.3.9 - 8.0.15 OS:Mac OS X
Assigned to: CPU Architecture:Any
Tags: csv, export

[25 Sep 2017 15:24] Michael Lyons
Description:
Somewhere between v6.3.4 and v6.3.9, WorkBench broke results exporting as CSV. Specifically, this seems to be related to escaping double-quotes.

I marked this as S2 because downgrading the client version is a workaround for us, but I don't know if there's a workaround in the latest version.

How to repeat:
I'm using a UTF-8 collation, but I don't expect that matters.

- New Query

- Run this SQL:

          select 'foo' as txt, NOW() as tmstmp, 'bar' as txt2, 'baz "with" quotes' as quot, 'biff with
          quotes "and" line
          breaks' as quotlf

- Click the little floppy next to the word "Export" above the results and save a CSV

## Expected Results (v6.3.4)

txt,tmstmp,txt2,quot,quotlf
foo,"2017-09-25 14:54:30",bar,"baz ""with"" quotes","biff with
quotes ""and"" line
breaks"

## Actual Results (v6.3.9)

txt,tmstmp,txt2,quot,quotlf
foo,"2017-09-25 11:00:16",bar,"baz "with" quotes","biff with
quotes "and" line
breaks"
[25 Sep 2017 18:20] Miguel Solorzano
Please try:

select 'foo' as txt, NOW() as tmstmp, 'bar' as txt2, 'baz "\"with"\" quotes' as quot, 'biff with
          quotes "and" line
          breaks' as quotlf
[26 Oct 2017 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[6 Mar 2019 20:54] Michael Lyons
This is a duplicate of https://bugs.mysql.com/bug.php?id=86666, but it is STILL PRESENT in version 8! Come on, guys.
[6 Mar 2019 22:01] Miguel Solorzano
Thank you for the bug report. Update version of the original bug report.
[7 Mar 2019 3:04] Michael Lyons
Updating version