Bug #87840 MySQL Workbench 6.3 passwords with special characters fail
Submitted: 22 Sep 2017 13:17 Modified: 25 Sep 2017 12:12
Reporter: Harmonic Apps Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:6.3.8 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:Any

[22 Sep 2017 13:17] Harmonic Apps
Description:
I am trying to connect to a remote DB through Standard TCP/IP over SSH.  I have passwords that have special characters including ^, #, {, }, (, ), [, or ].

When I attempt to use the password as-is, I get an "Access denied for user" error. When I connect to the DB through command line, as long as I surround the password in quotes, I can connect successfully.  I can SSH to the remote server successfully

I have tried saving my password in the vault surrounded in single and double quotes, but I still cannot connect to the DB. I have tried using the escape character "\" before every special character in the password, but that did not work.  With the exact same parameters, I tested my connection in SQL Maestro for MySQL and it worked.  I don't like that tool nearly as much as I like Workbench.

I have not found any documentation on MySQL's site for handling passwords with special characters in Workbench.

NOTE: This appears to be an issue specific to Windows (I'm using Windows 10).  MAC users have no issues accessing the DB with the same password through Workbench.

Any ideas?

How to repeat:
MySQL Workbench 6.3.8 > Setup New Connection
Connection Method: Standard TCP/IP over SSH
Configure SSH parameters (I'm not using a SSH Key File)
Configure MySQL parameters (I'm using a specific IP for the hostname, not localhost)
Click Test Connection
[22 Sep 2017 20:46] Miguel Solorzano
Thank you for the bug report. I couldn't repeat with version 6.3.9.
[25 Sep 2017 12:12] Harmonic Apps
I installed 6.3.9 and I still have the issue.  Try a password like ^CraZy#{)V].  Did you also try it through an SSH tunnel?