Bug #87798 dll wrong version
Submitted: 19 Sep 2017 7:13 Modified: 19 Sep 2017 8:22
Reporter: maxim evofZygyowd Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S2 (Serious)
Version:community-5.7.19.0 OS:Microsoft Windows (10)
Assigned to: CPU Architecture:Any
Tags: .NET connectot, installer, Visual Studio

[19 Sep 2017 7:13] maxim evofZygyowd
Description:
[A]MySql.Data.MySqlClient.MySqlConnection cannot be cast to [B]MySql.Data.MySqlClient.MySqlConnection. Type A originates from 'MySql.Data, Version=6.9.8.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d' in the context 'Default' at location 'C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\PrivateAssemblies\MySql.Data.dll'. Type B originates from 'MySql.Data, Version=6.9.9.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d' in the context 'Default' at location 'C:\Windows\Microsoft.Net\assembly\GAC_MSIL\MySql.Data\v4.0_6.9.9.0__c5687fc88969c44d\MySql.Data.dll'.

How to repeat:
use mysql-installer-community-5.7.19.0.msi. you should have
mysql for visual studio 1.2.7
and
mysql connector NET 6.9.9
installed.
next create empty project vb/c#, create form, place datagridview. choose data source and select any table to fill datagrid.
[19 Sep 2017 8:22] Chiranjeevi Battula
Hello Maxim,

Thank you for the bug report.
This is most likely duplicate of Bug #82617, please see Bug #82617

Thanks,
Chiranjeevi.