Bug #87673 mysql workbench does not understand !includedir in config files (my.cnf)
Submitted: 6 Sep 2017 0:47 Modified: 5 Oct 2017 6:10
Reporter: RAUL DIAS Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S5 (Performance)
Version:6.3.8, 6.3.9 OS:Linux (Ubuntu 17.04)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[6 Sep 2017 0:47] RAUL DIAS
Description:
When opening a my.cnf file, Workbench does not understand (and ignores) the !includedir directive.

How to repeat:
Create a my.cnf file and add to it:
!includedir /etc/mysql/conf.d/

Move the config to /etc/mysql/conf.d/ 

And use it from Workbench
[6 Sep 2017 9:26] Umesh Shastry
Hello RAUL DIAS,

Thank you for the report.

Thanks,
Umesh
[5 Oct 2017 6:10] Mike Lischke
This behavior is by design, as we also need to write back values, which would be very tricky with include files.