Bug #87601 cant view the navigator panel
Submitted: 30 Aug 2017 9:29 Modified: 30 Aug 2017 13:31
Reporter: Nishita Agarwal Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.3.9 OS:Microsoft Windows (Microsoft Windows 7 Home Premium Service Pack 1)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[30 Aug 2017 9:29] Nishita Agarwal
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\Nishita\AppData\Roaming\MySQL\Workbench\log\wb.log]

13:59:56 [ERR][      Workbench]: Console redirection failed.
13:59:56 [INF][      Workbench]: Starting up Workbench
13:59:56 [INF][      Workbench]: Current environment:
	Command line: "C:\Program Files\MySQL\MySQL Workbench 6.3 CE\MySQLWorkbench.exe" "C:\Users\Nishita\Documents\firstschema.mwb"
	CurrentDirectory: C:\Windows\system32
	HasShutdownStarted: False
	OSVersion: Microsoft Windows NT 6.1.7601 Service Pack 1
	SystemDirectory: C:\Windows\system32
	TickCount: 1798332
	UserInteractive: True
	Version: 4.0.30319.42000
	WorkingSet: 35192832
13:59:56 [INF][      Workbench]: Environment variables:
	SystemDrive = C:
	ProgramFiles(x86) = C:\Program Files (x86)
	Path = C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Sony\VAIO Startup Setting Tool;;C:\Program Files (x86)\Windows Live\Shared;C:\Windows\system32\config\systemprofile\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files (x86)\Java\jdk1.8.0_111\bin;C:\Program Files (x86)\Java\jdk1.8.0_111\bin;
	ProgramW6432 = C:\Program Files
	PROCESSOR_IDENTIFIER = Intel64 Family 6 Model 42 Stepping 7, GenuineIntel
	TMP = C:\Users\Nishita\AppData\Local\Temp
	PROCESSOR_ARCHITECTURE = AMD64
	PATHEXT = .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
	configsetroot = C:\Windows\ConfigSetRoot
	PROCESSOR_REVISION = 2a07
	TEMP = C:\Users\Nishita\AppData\Local\Temp
	USERPROFILE = C:\Users\Nishita
	LOGONSERVER = \\NISHITA-VAIO
	USERNAME = Nishita
	SystemRoot = C:\Windows
	FP_NO_HOST_CHECK = NO
	CommonProgramFiles = C:\Program Files\Common Files
	JRE_HOME = C:\Program Files (x86)\Java\jdk1.8.0_111\jre
	ProgramData = C:\ProgramData
	windows_tracing_logfile = C:\BVTBin\Tests\installpackage\csilogfile.log
	HOMEPATH = \Users\Nishita
	COMPUTERNAME = NISHITA-VAIO
	ALLUSERSPROFILE = C:\ProgramData
	CommonProgramW6432 = C:\Program Files\Common Files
	windows_tracing_flags = 3
	VS140COMNTOOLS = C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\
	SESSIONNAME = Console
	CommonProgramFiles(x86) = C:\Program Files (x86)\Common Files
	HOMEDRIVE = C:
	windir = C:\Windows
	CLASSPATH = C:\Program Files (x86)\Java\jdk1.8.0_111\lib;C:\Program Files (x86)\Java\jdk1.8.0_111\jre\lib;
	NUMBER_OF_PROCESSORS = 4
	OS = Windows_NT
	ProgramFiles = C:\Program Files
	ComSpec = C:\Windows\system32\cmd.exe
	JAVA_HOME = C:\Program Files (x86)\Java\jdk1.8.0_111
	PSModulePath = C:\Windows\system32\WindowsPowerShell\v1.0\Modules\
	APPDATA = C:\Users\Nishita\AppData\Roaming
	USERDOMAIN = Nishita-VAIO
	PROCESSOR_LEVEL = 6
	LOCALAPPDATA = C:\Users\Nishita\AppData\Local
	JDK_HOME = C:\Program Files (x86)\Java\jdk1.8.0_111
	PUBLIC = C:\Users\Public
13:59:57 [INF][      Workbench]: Current version given by meta info is: 6.3.9
13:59:57 [INF][      Workbench]: Setting PATH to: C:\Windows\system32;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Sony\VAIO Startup Setting Tool;;C:\Program Files (x86)\Windows Live\Shared;C:\Windows\system32\config\systemprofile\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files (x86)\Java\jdk1.8.0_111\bin;C:\Program Files (x86)\Java\jdk1.8.0_111\bin;
13:59:57 [INF][ mforms managed]: Initializing mforms wrapper
14:00:01 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	plugin path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	struct path: 
	module path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE/modules
	library path: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	user data dir: C:\Users\Nishita\AppData\Roaming\MySQL\Workbench
	open at start: C:\Users\Nishita\Documents\firstschema.mwb
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
14:00:01 [INF][      WBContext]: WbContext::init
14:00:18 [INF][            WBA]: Looking for extension modules for WBA...
14:00:18 [INF][            WBA]: 0 extension modules found
14:00:22 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Windows version 6.3.9 CE build 10690321 (64 bit)
	Configuration Directory: C:\Users\Nishita\AppData\Roaming\MySQL\Workbench
	Data Directory: C:\Program Files\MySQL\MySQL Workbench 6.3 CE
	Cairo Version: 1.10.2
	OS: Microsoft Windows 7 Home Premium Service Pack 1
	CPU: 4x Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz, 4.0 GiB RAM
	Active video adapter NVIDIA GeForce 410M
	Installed video RAM: 512 MB
	Current video mode: 1366 x 768 x 4294967296 colors
	Used bit depth: 32
	Driver version: 8.17.12.6721
	Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
	Current user language: English (India)

14:00:23 [INF][      Workbench]: UI is up
14:00:30 [INF][      Workbench]: Running the application
14:35:55 [INF][ Canvas backend]: Found OpenGL version for this view: 4.1.0
14:36:11 [WRN][               ]: MiniView::set_active_view got nil canvas
14:37:10 [INF][ Canvas backend]: Found OpenGL version for this view: 4.1.0
14:37:49 [WRN][               ]: MiniView::set_active_view got nil canvas
14:44:51 [INF][ Canvas backend]: Found OpenGL version for this view: 4.1.0
14:44:57 [WRN][               ]: MiniView::set_active_view got nil canvas

How to repeat:
i am sure its not a bug but i am new to workbench. i have been trying to add data to my tables. i searched the documentation,google,youtube for instructions but everywhere the process shown is through the navigator panel. i cant find any option to view my navigator panel. on the left hand side only description editor is visible. kindly tell me the ways to enter data in my tables or how to get the navigator panel(visual sql editor) in view.
[30 Aug 2017 13:31] Chiranjeevi Battula
Hello  Nishita,

Thank you for the bug report.
User Manual for data inserting into MySQL table using workbench:
https://dev.mysql.com/doc/workbench/en/wb-getting-started-tutorial-adding-data.html

Thanks,
Chiranjeevi.