Bug #87557 MySQL Instance crashes randomly
Submitted: 28 Aug 2017 7:18 Modified: 28 Aug 2017 7:42
Reporter: Jens Westerfeld Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S2 (Serious)
Version:5.5.54-0ubuntu0.14.04.1 OS:Linux (3.13.0-107-generic)
Assigned to: CPU Architecture:Any
Tags: galera, MySQL Thread pointer Exception, out_of_range

[28 Aug 2017 7:18] Jens Westerfeld
Description:
We got several MySQL Servers version 5.5.54 running on Ubuntu Trusty.
They are clustered via galera-3 version 25.3.20 from http://releases.galeracluster.com/ubuntu.
In irregular intervals some of them crash. Most of the time a "service mysql start" is enough to bring them up again.

Here is the output from mysql error.log:

/var/log/mysql/error.log
terminate called after throwing an instance of 'std::out_of_range'
  what():  vector::_M_range_check
17:45:29 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

key_buffer_size=67108864
read_buffer_size=131072
max_used_connections=20
max_threads=512
thread_count=3
connection_count=3
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 268960 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x30000
/usr/sbin/mysqld(my_print_stacktrace+0x2c)[0x93b83c]
/usr/sbin/mysqld(handle_fatal_signal+0x357)[0x697d17]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x10330)[0x7f0f3879c330]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0x37)[0x7f0f37bddc37]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x148)[0x7f0f37be1028]
/usr/lib/x86_64-linux-gnu/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x155)[0x7f0f384e8535]
/usr/lib/x86_64-linux-gnu/libstdc++.so.6(+0x5e6d6)[0x7f0f384e66d6]
/usr/lib/x86_64-linux-gnu/libstdc++.so.6(+0x5e703)[0x7f0f384e6703]
/usr/lib/x86_64-linux-gnu/libstdc++.so.6(+0x5e922)[0x7f0f384e6922]
/usr/lib/x86_64-linux-gnu/libstdc++.so.6(_ZSt20__throw_out_of_rangePKc+0x67)[0x7f0f38538447]
/usr/sbin/mysqld[0xaf641e]
/usr/sbin/mysqld[0xaf7ab9]
/usr/sbin/mysqld[0xaf8d91]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x8184)[0x7f0f38794184]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d)[0x7f0f37ca137d]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
No steps necessary, the instance crashes on its own.

Suggested fix:
Provide more specific error messages, avoid the shutdown..
[28 Aug 2017 7:42] Umesh Shastry
Hello Jens Westerfeld,

Thank you for the report.
This is duplicate of Bug #84940(base bug Bug #82842, which is private).

Thanks,
Umesh