Bug #87552 first select takes minutes
Submitted: 26 Aug 2017 14:22 Modified: 14 Sep 2017 8:28
Reporter: László Fenyvesi Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S5 (Performance)
Version:6.3.9 OS:Microsoft Windows (Microsoft Windows 10 Home)
Assigned to: CPU Architecture:Any
Tags: long, SELECT

[26 Aug 2017 14:22] László Fenyvesi
Description:
Per connection tab basis, the first select takes minutes to return the result set table. CPU/hard drive at 90-100%. Selects after this takes usual 0-0.3s. The first long selects shows 0s at Action Output Duration/Fetch column.

How to repeat:
With a simple select.

Suggested fix:
???
[26 Aug 2017 14:23] László Fenyvesi
wblog file

Attachment: wb.log (application/octet-stream, text), 1.80 MiB.

[26 Aug 2017 14:26] László Fenyvesi
With a previous version of WB these selects return in usual 0-0.3s but that version was buggy in another way (crashes)
[26 Aug 2017 16:12] Miguel Solorzano
Thank you for the bug report. I couldn't repeat on 2 different machines running Windows 10 Pro, so I assume your behavior is related to your environment, try skip-name-resolve, read:

https://dev.mysql.com/doc/refman/5.7/en/host-cache.html
[26 Aug 2017 22:27] László Fenyvesi
Thank you,
I read the link you provided and tried:
1) --skip-name-resolve option (Net start MySQL57 --skip-name-resolve option)
2) host_cache_size system variable to 0 or increase it

But it is the same.

Some other info:
1) during that 1-2 minutes the whole window is frozen and a "Not responding" text appears at the window heading
2) the mouse cursor is sandglass
 I don't think it is a server issue , it started when I updated to WB version 6.3.9.
Any other idea? Or something else that I can provide to help?
[7 Sep 2017 12:30] László Fenyvesi
I noticed that not only SELECTs but any action (drop, test connection etc.) is buggy when that is the first.
[14 Sep 2017 8:28] László Fenyvesi
Hi, can you help me about this bug?
I believe it you can't repeat it but have you seen the wb.log file?
More than 30000 rows, 1.8Mb, is this normal after a simple SELECT statement?
With a bunch of "[ERR][  XML Functions]: LibXml" entries.
These rows are always written when I connect to a server firstly so I think this is the problem.
When I turn off logging under Prefs than the problem solved (but without logging).