Bug #87548 Info missing from Show Table Status in 8.02
Submitted: 25 Aug 15:13 Modified: 16 Nov 10:06
Reporter: Peter Brawley (Basic Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: DML Severity:S3 (Non-critical)
Version:8.0.2 OS:Ubuntu (lubuntu 17.04)
Assigned to:

[25 Aug 15:13] Peter Brawley
Description:
In 8.0.2, many Show Table Status columns now show null ...

benchmark> SHOW TABLE STATUS from graphs WHERE name='familytree'\G
*************************** 1. row ***************************
           Name: familytree
         Engine: InnoDB
        Version: 10
     Row_format: Dynamic
           Rows: NULL
 Avg_row_length: NULL
    Data_length: NULL
Max_data_length: NULL
   Index_length: NULL
      Data_free: NULL
 Auto_increment: NULL
    Create_time: 2017-08-22 20:19:59
    Update_time: NULL
     Check_time: NULL
      Collation: latin1_swedish_ci
       Checksum: NULL
 Create_options: 
        Comment: 
1 row in set (0.00 sec)

How to repeat:
as above
[26 Aug 1:29] Godofredo Miguel Solorzano
Thank you for the bug report.

Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 7
Server version: 8.0.3-rc-debug Source distribution

Copyright (c) 2000, 2017, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql 8.0 > use test
Database changed
mysql 8.0 > create table tb (id int not null auto_increment primary key, sym char(1));
Query OK, 0 rows affected (0.07 sec)

mysql 8.0 > insert into tb (sym) values ('a'), ('b'), ('g');
Query OK, 3 rows affected (0.02 sec)
Records: 3  Duplicates: 0  Warnings: 0

mysql 8.0 > SHOW TABLE STATUS from test WHERE name='tb'\G
*************************** 1. row ***************************
           Name: tb
         Engine: InnoDB
        Version: 10
     Row_format: Dynamic
           Rows: NULL
 Avg_row_length: NULL
    Data_length: NULL
Max_data_length: NULL
   Index_length: NULL
      Data_free: NULL
 Auto_increment: NULL
    Create_time: 2017-08-25 22:21:48
    Update_time: NULL
     Check_time: NULL
      Collation: utf8mb4_0900_ai_ci
       Checksum: NULL
 Create_options: 
        Comment: 
1 row in set (0.01 sec)

Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 2
Server version: 5.7.20 Source distribution 2017-AUG-15

Copyright (c) 2000, 2017, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names mmiguel@ural:~/dbs $ ./57c
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 2
Server version: 5.7.20 Source distribution 2017-AUG-15

Copyright (c) 2000, 2017, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to c
   Index_length: NULLlear the current input statement.

mysql 5.7 > use test
Database changed
mysql 5.7 > show tables;
Empty set (0.00 sec)

mysql 5.7 > create table tb (id int not null auto_increment primary key, sym char(1));
Query OK, 0 rows affected (0.03 sec)

mysql 5.7 > insert into tb (sym) values ('a'), ('b'), ('g');
Query OK, 3 rows affected (0.02 sec)
Records: 3  Duplicates: 0  Warnings: 0

mysql 5.7 > SHOW TABLE STATUS from test WHERE name='tb'\G
*************************** 1. row ***************************
           Name: tb
         Engine: InnoDB
        Version: 10
     Row_format: Dynamic
           Rows: 3
 Avg_row_length: 5461
    Data_length: 16384
Max_data_length: 0
   Index_length: 0
      Data_free: 0
 Auto_increment: 4
    Create_time: 2017-08-25 22:16:20
    Update_time: 2017-08-25 22:17:06
     Check_time: NULL
      Collation: latin1_swedish_ci
       Checksum: NULL
 Create_options: 
        Comment: 
1 row in set (0.01 sec)

mysql 5.7 > exit
Bye
[29 Aug 13:17] Abhishek Ranjan
Posted by developer:
 
The bug will be fixed with Patch of Bug#26203731
[16 Nov 10:06] Erlend Dahl
Duplicate of

Bug#83957 Information_Schema.TABLES table statistics are NULL