Bug #87537 InnoDB: Assertion failure in thread 140321689343744 in file os0file.cc line 4947
Submitted: 25 Aug 2017 5:22 Modified: 25 Aug 2017 9:23
Reporter: Mothupi Mohlapamafsi Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.6.19 OS:Ubuntu (14.04.4 TLS)
Assigned to: CPU Architecture:Any
Tags: assertion failure

[25 Aug 2017 5:22] Mothupi Mohlapamafsi
Description:
2017-08-22 17:45:05 7f9f30729700  InnoDB: Assertion failure in thread 140321689343744 in file os0file.cc line 4947
InnoDB: Failing assertion: slot != NULL
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
15:45:05 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

key_buffer_size=51539607552
read_buffer_size=131072
max_used_connections=209
max_threads=600
thread_count=71
connection_count=59
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 50570255 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x30000
/usr/sbin/mysqld(my_print_stacktrace+0x2c)[0x7fbc1bfc71cc]
/usr/sbin/mysqld(handle_fatal_signal+0x3d2)[0x7fbc1bd27572]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x10340)[0x7fbc1aa3c340]
/lib/x86_64-linux-gnu/libc.so.6(gsignal+0x39)[0x7fbc1a092bb9]
/lib/x86_64-linux-gnu/libc.so.6(abort+0x148)[0x7fbc1a095fc8]
/usr/sbin/mysqld(+0x807587)[0x7fbc1c0d8587]
/usr/sbin/mysqld(+0x9150e2)[0x7fbc1c1e60e2]
/usr/sbin/mysqld(+0x86f038)[0x7fbc1c140038]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x8182)[0x7fbc1aa34182]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d)[0x7fbc1a156fbd]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
2017-08-22 17:45:15 14961 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.

How to repeat:
Not sure,It is the first this happens
I am looking for a solution

Suggested fix:
Not sure
[25 Aug 2017 5:25] Mothupi Mohlapamafsi
For More Information,
MySQL Crushed and automatically recovered because of this failure,leaving few tables broken and needing some repair
[25 Aug 2017 9:23] Miguel Solorzano
Thank you for taking the time to report a problem.  Unfortunately you
are not using a current version of the product you reported a problem
with (today version 5.6.37) -- the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/.

Also, there is no test case provided in the bug report and hence there
is nothing we can verify here.  If you are able to reproduce the bug
with one of the latest versions, please attach the exact reproducible
test case and change the version on this bug report to the version you
tested and change the status back to "Open".  Again, thank you for your
continued support of MySQL.