Bug #8743 Cannot connect to MySQL on localhost
Submitted: 23 Feb 2005 19:14 Modified: 24 Feb 2005 5:09
Reporter: Kirk Bowman Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Administrator Severity:S1 (Critical)
Version:1.0.3 alpha OS:Mac OS X (Mac OS X 10.3.8)
Assigned to: CPU Architecture:Any

[23 Feb 2005 19:14] Kirk Bowman
Description:
Mac OS X 10.3.8
MySQL 4.0.22-standard
MySQL Administrator 1.0.3 alpha

Unable to connect to mysql running on localhost. Reports the following error.

Connectinon Error
Could not connect to MySQL instance at localhost.
Error: Unknown system variable 'sql_mode' (code 1193)
Click the 'Ping Host' button to see if there is a network problem.

Pinging the host is successful.

How to repeat:
1) Launch MySQL Administrator
2) Enter host name "localhost"
3) Enter port "3306"
4) Enter username "root"
5) Enter password "secret_password"
6) Click Connect button

Suggested fix:
Unknown
[23 Feb 2005 19:28] Kirk Bowman
What further information can I provide so you can reproduce the bug?
[23 Feb 2005 19:29] Miguel Solorzano
Looks this issue belongs to client library MA was linked.
Please try to use a server 4.1.XX or 5.0.XX.
[23 Feb 2005 19:39] Kirk Bowman
I tried upgrading to mysql 4.0.23-standard and got the same error.

I checked the my.cnf file and could not find a variable called "sql_mode".

Will the final version support mysql 4.0.x?
[23 Feb 2005 19:55] Miguel Solorzano
Yes MA currently not works with servers 4.0.XX. Then you need
server version 4.1.XX and up.
[24 Feb 2005 5:09] Alfredo Kojima
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html

Additional info:

This bug happens when connecting to 4.0 servers only. The next release (to be made on Feb/24)
will have it fixed.
[23 Nov 2005 8:17] Spyros Papantoniou
Same problem on Suse Linux 10.0 with MA 1.1. Any ideas how to connect?