Bug #87284 MySQL for Excel button won't appear in the ribbon
Submitted: 2 Aug 2017 15:02 Modified: 18 Dec 2018 5:21
Reporter: b g Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S1 (Critical)
Version:1.3.7 OS:Microsoft Windows (Windows 7, 64 bits)
Assigned to: CPU Architecture:Any
Tags: Office Excel 2007

[2 Aug 2017 15:02] b g
Description:
This used to work alright until today. But when I first opened Excel today, the button had disappeared from the ribbon.

I also got a pop-up message box in Excel warning about a serious incident had happened (no further details in this box).

I removed and reinstalled the plug-in but nothing changed.

Looking at FAQ 9.2 in MySQL for Excel user guide, I checked and noticed that the add-in type is indeed flagged as "COM" in my Excel.

In case this might be of any interest, I tried and installed MySQL Workbenck last version(then removed) last friday, and got other issues since then (ODBC connector installed but no more visible in windows connectors list).

Many thanks for your help.

How to repeat:
Install the addon version 1.3.7.

Open a random excel workbook.

Check if the button is there.
[3 Aug 2017 6:46] Chiranjeevi Battula
Hello bg,

Thank you for the bug report.
Verified this behavior on MS Excel 2013 with MySQL for Excel 1.3.7.

Thanks,
Chiranjeevi.
[3 Aug 2017 6:48] Chiranjeevi Battula
Screenshot

Attachment: 87284.JPG (image/jpeg, text), 200.36 KiB.

[3 Aug 2017 7:41] b g
Hello Chiranjeevi,

I also checked the add-on was in my program list (since I installed and reinstalled it).

Is there something else I should check, especially regarding the FAQ point about the COM type ?

Rgds,
[3 Aug 2017 9:51] b g
I eventually found out why the button had disappeared.

This was most likely due to the MS Office 'Data Execution Prevention' (DEP) feature:

https://support.office.com/en-us/article/Why-is-my-add-in-crashing-1e02d873-04c8-4ecd-ac63...

Attached are a few screenshots of the steps taken (after recovery) to get the button back in the ribbon and re-enable the add-in.

Hope this will help.
[3 Aug 2017 9:52] b g
Re-enabling MySQL for Excel add-in

Attachment: MySQLforExcel_add-in_recovery.doc (application/msword, text), 1.51 MiB.

[18 Dec 2018 5:21] Javier TreviƱo
Hi b g,
Thanks for the bug report and for attaching the Word document with some screenshots.  Unfortunately the bug was incorrectly validated, the way the support rep tried to duplicate the problem is wrong, since it's a known issue that Excel 2013 does not show the add-in in the ribbon unless an Office hotfix is installed.

In your specific case we need to know what actions triggered the Data Execution Prevention to disable the add-in. What you experienced is not normal, and in order to verify the bug report and duplicate the issue you reported we need DEP to disable the add-in.

Do you have a set of steps to follow that can make DEP disable the add-in?

Thanks.