Bug #87208 Flow control mechanism does not prevent nodes from lagging further behind
Submitted: 26 Jul 2017 14:05 Modified: 31 Jul 2017 12:24
Reporter: Kenny Gryp Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Group Replication Severity:S3 (Non-critical)
Version:5.7.18 OS:Any
Assigned to: Bogdan Kecman CPU Architecture:Any

[26 Jul 2017 14:05] Kenny Gryp
Description:
Marco Tusa wrote a blogpost named "Group-Replication, sweet & sour" on some testing he has done.
http://www.tusacentral.net/joomla/index.php/mysql-blogs/191-group-replication-sweet-a-sour...

To me, the important point that he made is that Group Replication allows nodes to lag further behind than the configured flow control setting and keep it lagging behind even further even when flow control is active on the nodes.

How to repeat:
See http://www.tusacentral.net/joomla/index.php/mysql-blogs/191-group-replication-sweet-a-sour...

Suggested fix:
Ensure the flow control algorithm prevents nodes from lagging further behind. Should the QUOTA mode be slowing down even more as nodes are lagging?
[26 Jul 2017 14:09] Kenny Gryp
I saw that this bug is most likely fixed with the ability to fine tune flow control in 8.0.2 as I found (thanks @lefred) in https://dev.mysql.com/worklog/task/?id=9838

Can we get this in 5.7? (-:
[31 Jul 2017 12:24] Bogdan Kecman
Hi,

The way it works, with a minimum commit rate for flow-control, there is a limit how much it can slow down the system. It will *never* fully slow down the system!

If you set the threshold to a bit less then 1000 in your case, it might work, but really to discuss proper configuration for your system you should contact MySQL Support team, not write a bug :D as this is not a bug.

Best regards
Bogdan