Bug #87168 Working with darker colors
Submitted: 22 Jul 2017 9:17 Modified: 24 Jul 2017 10:12
Reporter: Guido Bartels Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S5 (Performance)
Version:6.3.9 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[22 Jul 2017 9:17] Guido Bartels
Description:
I am using the workbench under Windows 10 Por and with the color theme "High Contrast" with a dark brown background.

But now i can notread the second / fourth (and so on) line because of the color is similar to the font color. The even rows have nearly the same font and background color.

I tried to change some colors but without success.

What can i do to change the font color of even rows or the background color of the result could be all the time the same?!

Thanks,
Guido Bartels

How to repeat:
Just change the windows color to "High Contrast" and chose a dark background color for the window background.

At Workbench, just change the under preferences/Font & Color/ color scheme to "High Contrast"

fire a SQL Statement with more than 1 result and see that the even lines can't be read. 

Suggested fix:
Please let us change all the colors, also even lines.
[22 Jul 2017 9:21] Guido Bartels
Workbench SQL Result with wrong colors at even lines

Attachment: Workbench-Color-Problem.png (image/png, text), 114.81 KiB.

[24 Jul 2017 10:12] Chiranjeevi Battula
Hello Guido Bartels,

Thank you for the bug report.
This is most likely duplicate of Bug #72372, please see Bug #72372.

Thanks,
Chiranjeevi.