Bug #87119 MySqlWorkbench command line options not working as documented
Submitted: 19 Jul 2017 14:24 Modified: 20 Jul 2017 14:02
Reporter: Tom Grant Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.9 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[19 Jul 2017 14:24] Tom Grant
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\tgrant\AppData\Roaming\MySQL\Workbench\log\wb.log]

I can not get the command line MySqlWorkbench.exe to work as documented.

I try "MySqlWorkbench.exe -version" and all that happens is Workbench opens to the Welcome screen.  Does not show version anywhere.

I have tried the -query option.  I have tried the -script option.  None of them work.  I have also tried with --query.  That works.  Or seems to.  I get a tab using the connection stated in the --query option.  Documentation clearly says that on windows you use -query.   

How to repeat:
Run MySqlWorkbench.exe -version from command line.
[20 Jul 2017 14:02] Umesh Shastry
Hello Tom Grant,

Thank you for the report and feedback!

Thanks,
Umesh