Bug #87074 MySQL Workbench and OGR2OGR
Submitted: 14 Jul 2017 15:29 Modified: 16 Jul 2017 6:17
Reporter: Joaquim Seixas Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.3.9 64 bits OS:Microsoft Windows (10)
Assigned to: CPU Architecture:Any
Tags: MySQL Workbench, OGR2OGR

[14 Jul 2017 15:29] Joaquim Seixas
Description:
Hello, 

In Workbench Navigator, when I select a schema and I click on the button on the right side of the mouse, in the box that opens, an option with the name "LOAD SPATIAL DATA" appears. I click on it and opens a box. In this box I select a shapefile but when I click in NEXT, the Workbench said that don't find the PATH to the OGR2OGR. 

Trying to solve this, I have open the “Environment Variables" (in Windows 10) and I have add the path to my Workbench installation. 

I have restart the PC. 

I open the CMD and I try to run ogr2ogr. It runs with no error message. 

I open the MySQL Workbench 6.3 CE and select a schema and tried to use the "load spatial data" and I obtain the same error: 
Can´t find ogr2ogr and ogrinfo. Verify the PATH".... 

Regards

How to repeat:
Whenever I try to use the "Load Spatial Data" command in Workbench, I get the same error message.
[14 Jul 2017 20:52] Miguel Solorzano
Thank you for the bug report. Are you able to attach screen-shots of the issue (use the tab Files for). Thanks in advance.
[15 Jul 2017 9:08] Joaquim Seixas
MySQL Workbench ogr2ogr 1

Attachment: MySQL OGR2OGR 1.png (image/png, text), 200.90 KiB.

[15 Jul 2017 9:09] Joaquim Seixas
MySQL Workbench ogr2ogr 2

Attachment: MySQL OGR2OGR 2.png (image/png, text), 153.92 KiB.

[16 Jul 2017 6:17] Umesh Shastry
Thank you for the feedback!
Verified as described with WB 6.3.9 on Win7.

Thanks,
Umesh